Go Down

Topic: Arduino Uno R3: Stuck at 'Uploading...' (mac) (Read 929 times) previous topic - next topic

xscanna

Feb 19, 2016, 04:25 pm Last Edit: Feb 19, 2016, 05:05 pm by xscanna
Hello,

Although I am a software developer, I am new to the arduino world. I have recently purchased an arduino UNO R3 from adafruit. After installing the latest software from the arduino website (1.6.7) I am encountering the following problem:

I simply cannot upload anything on the arduino uno from my mac (El Capitan). The sketches compile just fine but when I hit the upload button it simply goes on forever. I have also noticed that when I open the activity monitor utility, the kernel_task is way above 120%

And yes, I did select the correct board (Arduino/Genuino UNO). Also, the serial ports available to me are: /dev/cu.Bluetooth-Incoming-Port and /dev/cu.usbmodem1A21


The arduino works perfectly fine since I was able to plug it and play on my girlfreind's mac. The only difference I noticed is that her serial port differs from mine. Her port is /dev/cu.usbmodem641.

Any idea?
Thanks a lot!


codlink

Only thing I can suggest is to install an earlier version, 1.6.5 is the most stable right now.
//LiNK

xscanna

I tried that but still the same.

I have just connected the Arduino to another mac (El Capitan) and it worked fine. Since the Arduino works on other macs running El Capitan I think the problem has to do with my old macbook pro (early 2008), which also runs El Capitan.

I have also checked for other programs running in the background that might interfere with the serial port used by the Arduino without success. When I hit the upload button it seems as if an infinite loop runs in the background, which makes the kernel_task to go up a lot. The orange upload button is stuck and not responding.

I am running out of ideas.

Thanks!

Gengis

I had the problem you described with my 2008 MacBook Pro running El Capitan.
After some research online I solved the problem by connecting the Arduino board to a powered USB hub.
It seems the problem is generated by insufficient power delivered by the USB port of the computer, creating communication problems with the driver.

Hope this helps.
Gianluca

muxa

I have the same problem with my old MacBook Pro 2008 running El Capitan. No one problem with the same Arduino and the same USB cable with new MacBook Pro running Sierra (and El Capitan before).
Also, no one problem on that old MacBook Pro with non-original Arduinos that require custom USB driver (CH34X).
Also, I have Windows 7 on that old MacBook Pro (in VirtualBox) and it doesn't have any problem with the original Arduino connected to the same "problematic" USB port.
So, it is a problem with particular USB driver for old MacBook Pro.

theropod

You might try the link below. I updated to Sierra and my mini lost the ability to see my clone Nano. The new usb driver fixed my issue.

https://codebender.cc/static/walkthrough/page/3

Go Up