Go Down

Topic: nrf24l01+ pa lna having to touch antenna (Read 5758 times) previous topic - next topic

batata004

Hi,

I bought a more powerful nrf24l01+ with PA and LNA to get better range but it's much worst than my normal nrf24l01+. After playing around with it I discovered that when I touch the antenna or the header of the pins and keep my finger there the transmitter works really great but if I remove my finger the modules works like crap.

How can I solve this problem?

aarg

  ... with a transistor and a large sum of money to spend ...
Please don't PM me with technical questions. Post them in the forum.


jremington

There are several possibilities, including

1. The antenna is not properly connected, and you are acting as an antenna when you touch the module

2. The high power module is overloading the receiver, and when you touch it you are "shorting" the antenna to ground.

Are the transmitter and receiver modules close together during your tests? If so, move them far apart and test again.

6v6gt

This reminds me of my ultimately successful attempts to get two of these devices working together. My original prototype with a simple nRF24L01+ module worked fine (apart from the range). When I upgraded to the nRF24L01+PA+LNA - PA-IPX module the one I was using as transmitter exhibited the same problems you have described. Some of the things which helped, but I cannot now say which I finally used:

1. Adding an explicit radio.powerUp() statement before transmitting ( I was using the maniac-bug library - not necessarily a recommendation)
2. Following some of the advice in  http://arduino-info.wikispaces.com/Nrf24L01-2.4GHz-HowTo
3. Adding a high value capacitor on the power leads to the module.
4. ditto a low value capacitor
5. If the antenna was bent at 90 degrees, it would perform better.
6. If the radio module was in an antistatic bag with a hole cut for the antenna to protrude out, it had a beneficial effect (although the scientific basis is probably not strong, maybe some mild screening)

aarg

Also, what voltage are you running it on, and which Arduino? How is it powered?
  ... with a transistor and a large sum of money to spend ...
Please don't PM me with technical questions. Post them in the forum.

MarkT

Tighten up the aerial, maybe its loose, so that touching makes better contact?
[ I DO NOT respond to personal messages, I WILL delete them unread, use the forum please ]

aarg

I would look closely at the soldering on the SMA connector (well, everywhere if that doesn't turn up anything). Sometimes solder breaks can be nearly invisible, so you can try to reflow it.
  ... with a transistor and a large sum of money to spend ...
Please don't PM me with technical questions. Post them in the forum.

batata004

Thank you all, I did everything you said, added 2 capacitors, made a hole in the antistatic bag... everything you told me. And I still have the same problem. I saw a post on the internet of a guy who used aluminum foil all around the module and IT WORKED! But it's not reliable, sometimes it works sometimes all connections fail.

I have no idea why aluminum foil helped but it's not reliable, maybe I should touch the foil in some specific part of the module? Should I ground the foil?

jremington

I would throw the modules away and start over.

batata004

I discovered someting useful: when I detach the antenna everyting works fine! I dont need to touch the module to make it work but I cant get a good range (10m at top). As soon as I put the antenna I realized I need to touch it's base (right after thte gold connector) to make the module work. Any idea how I can make this work?

Watcher

I am also straggling with a couple of similar modules...My project works perfect with the low power - non-amplified versions but as soon as i replace one with the powered nrf24 module, the sketch freezes when it tries to transmit.

Touching the module at various points seems to have some kind of effect but I have never managed to get things working. I have tried to remove the antenna, use an attenuator,  aluminum foil shield, moved the module 30-40cm away from the rest of the circuit.

Nothing worked. Decided to order another pair and try again.

Grumpy_Mike

#12
Mar 02, 2016, 06:57 pm Last Edit: Mar 02, 2016, 06:59 pm by Grumpy_Mike
Quote
I have no idea why aluminum foil helped
The foil acts as a ground plane for the antenna. The foil must be connected to the ground.

The antenna is reflected electrically in the foil to make it double the size and make it a half wavelength long instead of a quarter.

From:- https://en.wikipedia.org/wiki/Ground_plane

alsantour

In case someone is still looking at this in 2018 (through google as i was) ... i had the same problem, swapping the high power transmitter with the small one would eliminate the problem.

When the high power trasmitter is connected it would seem like it is not transmitting, but then transmit if i touch the antenna or various spots on the board... Removing the antenna would get it to work but not with a good range...

I am using the power regulator breakout board to connect through that to the arduino , so knew it wasnt a 3.3-5v issue, also do not need to add filter capacitor since they are included on the board.

I thought using an anti-static bag with a hole in it is the most ridiculous idea until i tried it and it worked!! I am baffled.

Grumpy_Mike

Quote
swapping the high power transmitter with the small one would eliminate the problem.
But it was not the drop in power that caused it to work. It was the fact that it was a different transmitter with different output characteristics that was a better match to your antenna.

When there is a mismatch between transmitter and antenna impedance you set up standing waves in the lead and this absorbers the power so you were getting less power out of the antenna on your higher power transmitter than the lower power one.

Having a ground plane changes the impedance of the antenna and not only gives you a better match but also a better antenna.

Go Up