Go Down

Topic: Help (Read 332 times) previous topic - next topic

rcbarnhardt

When running any sketch on my board it stops working momentarily and becomes unresponsive, then after a couple of seconds continues, help?

codlink

How do you know it stops?
//LiNK

rcbarnhardt

Say for example, that I'm running the blink example, at random times the led will stop blinking or stay on, and after a few seconds it will resume normal functionality. If I did this with a button sketch, it would, for a few seconds, become unresponsive to the button and stay on or off. Also happens with servos and sensors, even with an external power source, to the servo that is.

weedpharma

Have you tried different power to the Arduino?

What is the amount of time it appears to stop for?

Does it still stop if nothing is connected besides power?

Load a program with a command to blink a LED on a pin only in setup(). Then run blink in the loop().  This will indicate if it is pausing or resetting.

Weedpharma

rcbarnhardt

I've tried with different power, a 12V 1A AC/DC adapter, and the problem persists. The time it stops for is arbitrary, anywhere from 2 seconds to 10 or 15. I've just tested it with the led on pin 13 with this external power source and after a little while it happens. it will work normally, stop for 10 seconds and then keep going. I mean it's not every 3 seconds but if I wanted to do a longer term project where it required to be turned on of a reasonable amount of time i would have a problem. This being said, the problem seems less frequent using only the built in LED, than if I use a servo for example, even if with an external power source and only the signal cable goes to the board, I could make a video if it helped.

codlink

I could make a video if it helped.
Please do.  Please post the code you are using for blink in code tags.
//LiNK

Go Up