Go Down

Topic: erreur televersement (Read 2177 times) previous topic - next topic

edd52320

bonjour a tous
voila j ai un probleme de communication entre la carte et le pc je vous joint le message d erreur
Le croquis utilise 450 octets (1%) de l'espace de stockage de programmes. Le maximum est de 32 256 octets.
Les variables globales utilisent 9 octets (0%) de mémoire dynamique, ce qui laisse 2 039 octets pour les variables locales. Le maximum est de 2 048 octets.
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x3a
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x3a
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x3a
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x3a
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x3a
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x3a
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x3a
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x3a
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x3a
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x3a
Problème de téléversement vers la carte. Voir http://www.arduino.cc/en/Guide/Troubleshooting#upload pour suggestions.

la barre de televersement va jusqu au bout mais ne termine pas
j ai se probleme sur 2 de mes trois carte uno
j ai essayer pas mal de chose comme changer le nom de com sur le pc. changer de port usb du pc.

pourriez vous m aiguiller ??
merci

infobarquee

bonjour,
mauvais port COM

quel OS
quelle carte arduino
officielle ou china
AUCUNE AIDE PAR MP

edd52320

port com ok

OS: windows 10 ( merci de ne pas me taper sur les doigt je suis pas sur de ma reponse)

carte arduino uno china ( malgres que se soit bien marquer arduino uno tous comme une commander en france )

et il semblerai bien que se soit la cause du probleme !!! je m explique
j ai egalement commander un micro controler (atmega 328) seul et la pas moyen de lui mettre qque chose dedans ( le code erreur n etant quand meme pas identique a celui la ) j ai donc tester ce microcontroler sur une uno commander en france sur un site connu au final meme probleme
quand je prend les microcontroler des carte china et que je le met sur ma carte "fr" j arrive a aller jusqu a la fin du televersement

se qui m etonne c est que j ai bien compile une bonne cinquantaine de programme different sur la carte av que le probleme apparaisse d un coup et apres plus moyen !!!

j ai lu en cherchant un peu qu on parlait de bootloader se terme m est completement inconnu peut il sagir d une partie de mon probleme ? pouvez vous m expliquer se terme ou si vous avez un lien en francais ( desole mon anglais est vraiment pas top lol ) je suis prenneur

infobarquee

cause du soucis = clone china
donc il faut mettre le bon driver dans windaub.
recherche sur le forum, Artouste a donné un lien pour ca.

ca a du arriver après une MAJ de windaub ;)
AUCUNE AIDE PAR MP

edd52320

j ai pas vue de mise a jour se mettre en place mais je vais essayer ta solution

edd52320

apres verification et test sur un autre pc ( windobe7) rien a faire
dans le gestionnaire de peripherique la ( les ) cartes sont bien reconnu ( enfin sauf une mais je pense qu elle est griller) sur des port com different et bien marquer arduino uno
je me penche de plus en plus  vers le prosseceur atmega328p-pu
j ai vue qu une autre personne a le meme probleme que moi je vais suivre aussi le post

je vais recherche comment faire un flash de la carte complete


ps: pas trouver le post d Artouste sur l installation des drivers si qqun me lit et qu il vois de quoi je parle se serrain gantil de le remetttre ici merci

infobarquee

AUCUNE AIDE PAR MP

edd52320


naute

Bonjour,

j ai egalement commander un micro controler (atmega 328) seul et la pas moyen de lui mettre qque chose dedans ( le code erreur n etant quand meme pas identique a celui la )
Pour ce problème, il est fort probable que ton ATMega n'ait pas de bootloader préchargé. Dans ce cas, soit tu charges le bootloader, soit tu utilises un programmateur. Le mieux est d'acheter l'ATMega préchargé.

j ai donc tester ce microcontroler sur une uno commander en france sur un site connu au final meme probleme
quand je prend les microcontroler des carte china et que je le met sur ma carte "fr" j arrive a aller jusqu a la fin du televersement
Normal car le contrôleur monté d'origine possède un bootloader. C'est la moindre des choses.

se qui m etonne c est que j ai bien compile une bonne cinquantaine de programme different sur la carte av que le probleme apparaisse d un coup et apres plus moyen !!!
C'est la définition même d'une panne. L'instant d'avant, ça fonctionnait, l'instant d'après, ça ne fonctionne plus. :smiley-mr-green:

j ai lu en cherchant un peu qu on parlait de bootloader se terme m est completement inconnu peut il sagir d une partie de mon probleme ? pouvez vous m expliquer se terme ou si vous avez un lien en francais ( desole mon anglais est vraiment pas top lol ) je suis prenneur
C'est un petit bout de code chargé dans un coin protégé de la mémoire flash et qui permet au contrôleur de savoir ce qu'il doit faire de ce qui lui arrive par le port série. Disons que, pour faire court, ça correspond au bios des ordinateurs.

Cordialement, naute  :smiley:

edd52320

merci naute

j ai donc essayer de bootloader un des micro-controleur a l aide de la derniere carte fonctionnelle
apres avoir fait un montage sur une breadboard (en verifint plusieur fois les branchement, on est jamais trop prudent) je me suis mis a la partie prog
j ai donc envoyer le programme arduino ISP dans la carte puis j ai connecter le controleur a bootloader
j ai ensuite fait cette mani:  outils>types de cartes > arduino duemilanove...
                                       outils >processeur > atmega 328
                                       "      "> port com> celui de ma carte d origine
                                       "      " > programmateur> AVR ISP
                                       "       " > graver la séquence d initialisation

et au bout de qque seconde voici se que ca me donne

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x03
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xe0
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xe0
Problème de téléversement vers la carte. Voir http://www.arduino.cc/en/Guide/Troubleshooting#upload pour suggestions.
 

mes questions

ai je fait une fausse manip dans l ordre des progammes?
y a t il un ficher a ajouter ( comme j ai vue sur plusieurs site) ? si oui ou le mettre ( il disent de mettre le fichier en .txt dans le " carnet de croquis" mais je n ai pas trouver se fichier "carnet" )
si aucun fichier a ajouter ai je selectionner la bonne carte lors du bootloade?

elektrax

Quote
j ai ensuite fait cette mani:  outils>types de cartes > arduino duemilanove.
pourquoi duemilanove ?

Quote
programmateur> AVR ISP
arduino as isp

montage breadboard : qtz+cond22pf+reset resistance+cond 100nf, + decouplage alim condo 100nf

il faudrait déjà voir dans le gestionnaire de périphériques ce qu'il indique pour CHAQUE carte, toutes tes cartes sont avec un m328p en boitier dip ?

naute

y a t il un ficher a ajouter ( comme j ai vue sur plusieurs site) ? si oui ou le mettre ( il disent de mettre le fichier en .txt dans le " carnet de croquis" mais je n ai pas trouver se fichier "carnet" )

Le carnet de croquis est le dossier dans lequel sont sauvegardés par défaut tes sketchs. Pour savoir où il se trouve, tu fais "Fichier >> Préférences", et dans la fenêtre qui s'ouvre, en haut à gauche, tu as l'emplacement du carnet de croquis. Tu peux d'ailleurs modifier cet emplacement si tu le souhaites.

Pour le reste, je n'ai pour l'instant pas d'idée  :( .

Cordialement, naute  :)

edd52320

naute merci je vais regarder

elektrax j avoue que j ai pas tous compris lol sur ma carte c bien marquer atmega 328p-pu
j ai selectionner duemilanove je ne me rapelle plus exactement pourquoi mais il me semble que sur le tuto ( enfin les tutos) il disai de prendre celui la ( histoire de choix apres entre atmega 328 et 128)

elektrax as tu deja realise des boots ???

mon erreur a l air de venir du programeur choisi. j ai choisis AVR ISP au lieu de "as ISP" je ferai des essais demain
merci pour les reponse

Go Up