Go Down

Topic: avr-g++: error: missing filename after '-o' (Read 1 time) previous topic - next topic

29holden

What does this mean? Please someone tell me!!! >:(  >:(

spycatcher2k

#1
Apr 08, 2016, 06:33 pm Last Edit: Apr 09, 2016, 11:24 am by spycatcher2k
It means you are using 1.6.6 and can't work out how to search the forum ! ! ! ! !

OOPS - Edit for wrong version
Mrs Drew
-=-
http://www.uk-pcb.co.uk - UK PCB Fab Company
I will design & code for you, but I will also charge you (PM me)
If you don't like my answers, realize : I'm not being cheeky, I'm Just trying to prompt you to use your own brain/google etc.

pert

The error is caused by using Arduino AVR Boards 1.6.10 with Arduino IDE 1.6.6, they are incompatible. The solution is to either:
  • Upgrade to Arduino IDE 1.6.7 or 1.6.8
  • Install Arduino AVR Boards 1.6.9 using Boards Manager(Tools > Board > Boards Manager... > Arduino AVR Boards(click on it) > Select version > 1.6.9 > Install) - I've had problems reinstalling the previous Arduino AVR Boards version with Boards Manager so you may have to reinstall the Arduino IDE if you can't compile after going back to Arduino AVR Boards 1.6.9.

DrAzzy

Note that 1.6.8 introduces a really bad bug on windows, so don't use that version if you're on windows.
ATTinyCore for x4/x5/x61/x7/x8/x41/1634/828/x313 megaTinyCore for the megaavr ATtinies - Board Manager:
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts, mosfets, awesome prototyping board in my store http://tindie.com/stores/DrAzzy

Go Up