Go Down

Topic: alimenter module en 3,3V (Read 457 times) previous topic - next topic

Rigolo

Bonjour,
J'essaye d'alimenter un module (BMP180) en Vin 3,3V via la sortie 13 (analoglWrite(13,170) ).
Le capteur ne marche pas.
Alors que j'ai bien 3,3V avec un voltmètre et quand je le câble sur la sortie "power 3,3V" il fonctionne normalement.
D'où vient l'erreur?

Jambe

D'où vient l'erreur?
A mon avis, le fait d'alimenter en pwm ne produit pas un "vrai" 3,3V (qu'on m'arrête si je me trompe), je sais pas si le capteur apprécie.

tu precises pas le type de carte. uno ou mega?

Rigolo


fdufnews

#3
Apr 23, 2016, 08:10 pm Last Edit: Apr 24, 2016, 02:58 pm by fdufnews
La sortie PWM délivre une tension hachée. Autant dire que le capteur risque pas de fonctionner.

Question, pourquoi n'utilises-tu pas tout simplement la sortie 3,3V présente sur la carte?

Yan_duino

si c'est pour eteindre le module,
le mieux c'est d'utiliser un mosfet que tu commande par une des sortie de l'arduino.

A+
Yan_duino

-Standby

Bonjour,
J'essaye d'alimenter un module (BMP180) en Vin 3,3V via la sortie 13 (analoglWrite(13,170) ).
Le capteur ne marche pas.
Alors que j'ai bien 3,3V avec un voltmètre et quand je le câble sur la sortie "power 3,3V" il fonctionne normalement.
D'où vient l'erreur?
C'est normal que ton multimetre t'affiche une tension de 3,3v, la periode de mesure du multimetre est tellement faible a celle du PWM qui ne voit que du 3,3v.

En tout cas ça sent le troll.
The Mind is like a parachute it works best when opened.

Go Up