Go Down

Topic: Verify/Compile error (Read 437 times) previous topic - next topic

muriphysics

Hi people, I'm new in Arduino's world. I'm using Anduino/Genuino UNO; It had been worked perfectly the lasts weeks, but the latest days is imposible to me to compile the sketch and I haven't made any changes.

When I try to compile the sketch appear the following errors:

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00

I have tried to solved this problem (checking port, bootloader, drivers...)...but there aren't changes in the response.

Somebody could hepl me, please?

Muri

johnwasser

#1
May 06, 2016, 12:58 am Last Edit: May 06, 2016, 12:59 am by johnwasser
Perhaps more data will help.  Go to the Preferences... and turn on:
    "Show verbose output during:  [  ] compilation    [X] upload".
 Then try the upload again and copy ALL of the messages to here.
Send Bitcoin tips to: 1G2qoGwMRXx8az71DVP1E81jShxtbSh5Hp

muriphysics

Ok. The message that appears is the following:

C:\Program Files\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM5 -b115200 -D -Uflash:w:C:\Users\MaViTe\AppData\Local\Temp\buildd2cd31f0e939e6d5d9d41a12412483fc.tmp/VERSION1LUX.ino.hex:i

avrdude: Version 6.0.1, compiled on Apr 15 2015 at 19:59:58
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "C:\Program Files\Arduino\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : COM5
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00

avrdude done.  Thank you.


Any idea?

DrAzzy

#3
May 06, 2016, 08:02 pm Last Edit: May 06, 2016, 08:03 pm by DrAzzy
Well, that's the error you'll get if you saw the board in half (between the usb serial and '328), or if you left somethign connected to pins 0 or 1, or if there's something breaking the autoreset, or the bootloader isn't present or isn't running - it's an incredibly uninformative error.

Is anything connected to pins 0 or 1? Is anything connected to reset? Could you have trashed the bootloader somehow?
ATTinyCore for x4/x5/x61/x7/x8/x41/1634/828/x313 megaTinyCore for the megaavr ATtinies - Board Manager:
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts, mosfets, awesome prototyping board in my store http://tindie.com/stores/DrAzzy

Go Up