Go Down

Topic: How to install avahi-browse. (Read 4392 times) previous topic - next topic

Jantje

May 19, 2016, 07:46 pm Last Edit: May 25, 2016, 12:29 am by Jantje
I need avahi-browse (or something similar) but when I try to install the package I get an error

Code: [Select]
opkg install avahi-utils
Installing avahi-utils (0.6.31-12) to root...
Downloading http://downloads.arduino.cc/openwrtyun/1.6.2/packages/packages/avahi-utils_0.6.31-12_ar71xx.ipk.
Installing libavahi-client (0.6.31-12) to root...
Downloading http://downloads.arduino.cc/openwrtyun/1.6.2/packages/packages/libavahi-client_0.6.31-12_ar71xx.ipk.
Installing avahi-dbus-daemon (0.6.31-12) to root...
Downloading http://downloads.arduino.cc/openwrtyun/1.6.2/packages/packages/avahi-dbus-daemon_0.6.31-12_ar71xx.ipk.
Configuring libavahi-client.
Collected errors:
 * check_data_file_clashes: Package avahi-dbus-daemon wants to install file /usr/sbin/avahi-daemon
        But that file is already provided by package  * avahi-nodbus-daemon
 * check_data_file_clashes: Package avahi-dbus-daemon wants to install file /etc/init.d/avahi-daemon
        But that file is already provided by package  * avahi-nodbus-daemon
 * opkg_install_cmd: Cannot install package avahi-utils.

This looks like some dependency problem between avahi-dbus-daemon and avahi-nodbus-daemon.
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

Jantje

I'm making more and more progress now. Basically this is the only yun shield problem I still have.
This is going to be a problem in the near future.

The problem I'm trying to fix is as follows.
Suppose you have a PC (called PC) and 2 yunshield robots (called robot1 and robot2).
From the bonjour enabled PC I can reach the robots with the name robot1.local and robot2.local.
However from robot1 I can not reach the pc or robot2. robot2.local and pc.local are unknown.

This problem existed on yun and I build a workaround based on avahi-browse but due to the error above I can not install avahi-browse https://github.com/arduino/openwrt-yun/issues/7

Input is welcomed :-)
Best regards
Jantje
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

Jantje

Some follow up:
Thanks to impressiver I have avahi browse working again. http://forum.arduino.cc/index.php?topic=402375
The steps are
Code: [Select]
$ opkg remove avahi-nodbus-daemon --force-depends
$ opkg update
$ opkg install dbus dbus-utils
$ opkg install avahi-dbus-daemon --force-overwrite
$ opkg install avahi-dnsconfd avahi-utils
$ reboot
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

Go Up