Go Down

Topic: Not able to upload sketch avrdude: ser_send(): write error: sorry no info avail (Read 8999 times) previous topic - next topic

ZekerPixels

Hello,

I'm not able to upload a sketch to the arduino, when i upload i get the message:
Code: [Select]
avrdude: ser_send(): write error: sorry no info avail

Just for testing I'm trying to upload is the Blink sketch, with just the bare board (so there is nothing connected accept from the USB).
Code: [Select]
void setup() {
  // initialize digital pin 13 as an output.
  pinMode(13, OUTPUT);
}

// the loop function runs over and over again forever
void loop() {
  digitalWrite(13, HIGH);   // turn the LED on (HIGH is the voltage level)
  delay(1000);              // wait for a second
  digitalWrite(13, LOW);    // turn the LED off by making the voltage LOW
  delay(1000);              // wait for a second
}


I'm using Windows 10 and this error keep accuring.
I tried the Arduino IDE V1.0, V1.0.5 and V1.6.8 and a couple of different USB cables. Also this error occurs when using a genuin Arduino Uno R3, Arduino Uno SMD and a Arduino nano.

I've the right board selected in the Arduino IDE and I have a COM port selected, the programmer is selected on AVRISP mkII.


Does anyone know a solution or something I can try to get it working?

Thanks for helping,
ZPx

FullOfBadIdeas

Could be a couple of things.  Just happened to me last night.   I went down this guys check list- problem solved before I reached the end of his list.  In my case- stuff plugged into pin 1. 

http://m.instructables.com/id/A-solution-to-avrdude-stk500getsync-not-in-syn/

DrAzzy

That typically indicates that the wrong serial port is selected, or the drivers are not correctly installed. Since the Uno and Nano have different serial interfaces, but you get the same error, I'm inclined to suspect that you're selecting some other serial port.
ATTinyCore for x4/x5/x61/x7/x8/x41/1634/828/x313 megaTinyCore for the megaavr ATtinies - Board Manager:
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts, mosfets, awesome prototyping board in my store http://tindie.com/stores/DrAzzy

ZekerPixels

I followed the Loop-Back Test Instruction with the Arduino Uno and everything I typed is transmitted back, so the communication is working, right?

Also this board has the bootloader (the led is flashing 3 timer after reset)

I also tried everything mentioned before on a Windows 7 computer, with the same results.

spycatcher2k

Mrs Drew
-=-
http://www.uk-pcb.co.uk - UK PCB Fab Company
I will design & code for you, but I will also charge you (PM me)
If you don't like my answers, realize : I'm not being cheeky, I'm Just trying to prompt you to use your own brain/google etc.

ZekerPixels

Yes, i've selected the right board.

I got it working on my windows 10 tablet, but i can't get it working op mijn desktop. Both are using Windows 10 (fresh instal from a couple of week ago), Arduino IDE V1.6.8 and thesame cables.

I have already tried to reinstal the Arduino IDE, removed and reinstaled the drivers, also tried differend usb ports and using a drifferend OS as virtual machine. I can do the Loop-Back Test but not upload.

Go Up