Go Down

Topic: [SOLVED] Mega 2560 Rev 3 + Yun Shield, "Connection refused" (Read 3425 times) previous topic - next topic

kantila

Hi all,

I've just received a fresh combination of Mega 2560 Rev 3 + Yun Shield. After pairing them and applying power through USB I've been able to access and configure the Yun shield through Wifi without problems. My only changes to the default configuration have been the assignment of a static ip in my local network and the change of the name of the Shield. I'm able to connect to the Shield with a browser and ssh without issues and the Wifi connection seems strong.

I've uploaded some of the example sketches to use the serial connection to print messages without any problems. However, since I'm planning to run this remotely, debuggin/logging my sketches through the Console instead of Serial would be the preferred solution. Unfortunately i'm not able to connect to the console when using the Console class.

When I change the port in Arduino IDE 1.6.9 to the network based, it gives me something like this:

Unable to connect: retrying (1)...
Unable to connect: retrying (2)... connected!
Connection closed by foreign host

When using "telnet localhost 6571" from the ssh console, the result is either

telnet: can't connect to remote host (127.0.0.1): Connection refused

or

Connection closed by foreign host

The result is the same with an empty sketch or every example sketch, for example

https://www.arduino.cc/en/Tutorial/ConsoleAsciiTable

that I have tried. I've upgraded the the Yun Shield from the original 1.6.1 to 1.6.2, r48749 with no change.

ps w | grep -i python

gives me

8837 root      9264 S    python -u bridge.py

After extensive Googling I've ran out of ideas how to debug this. I'm new to Arduino and wonder if I've done something wrong with the installation. What makes it hard to check this is that the whole product of Yun Shield seem to have vanished from arduino.cc this week including the "getting started" article.

Any help would be greatly appreciated!

- Kari




marcobrianza

Hi Kari, did you install a jumper in the ICSP of the 16U2?
that is required with boards with 1 serial port.


kantila

I did not. After inserting a jumper to those pins, both network port and telnet console seem to work. Many, many thanks for your informative picture!

This was a stupid mistake from me although the Yun Shield product page and link to the Yun Shield getting started is still missing. Another topic from yesterday

 http://forum.arduino.cc/index.php?topic=404530.0

has the link to the tutorial where the need of the jumper is explained.

Thanks again!

Priscilla

The Arduino Yun Shield has the same bridge design as early Dragino Yun Shield, so the manual is similiar. Dragino has a wiki page(http://wiki.dragino.com/index.php?title=Yun_Shield) for how to connect the Yun Shield to different Arduino board.  this could be a good reference to the Arduino Yun Shield How To.

Go Up