Go Down

Topic: Questions gpio + contrôle TV (Read 756 times) previous topic - next topic

Konolol

Jun 15, 2016, 02:40 pm Last Edit: Jun 15, 2016, 02:47 pm by Konolol
Bonjour à tous !

Alors voilà, j'ai récupéré une TV donc le récepteur IR est mort, et donc j'ai eu l'idée de rattacher les boutons intégrés à la TV au gpio de mon arduino pour contrôler la télé en wifi.

Cependant je me pose pas mal de questions (je suis développeur et mon niveau en Electronique s'approche d'un niveau collège)

L'idée c'est de souder des fils à la base des boutons intégrés à la TV et les connecter à des GPIO, mais voila, est-ce que les gpio peuvent supporter ça sans rien ou est-ce que je vais avoir besoin de relais ? (sachant que vu la place que j'ai dedans, des relais ça m'arrange pas :D)

De ce que j'ai pu mesurer, j'ai 3.25V au bornes des boutons et a priori 0ma



Voilà une petite photo du circuit de commande intégré.

J'espère avoir été clair et vous remercie par avance !

EDIT: j'ai oublié de préciser que j'utilise un esp8266

cbrandt

Utilise des optocoupleurs entre l'arduino et la tv, ils sont parfaits pour ça.

Konolol

Utilise des optocoupleurs entre l'arduino et la tv, ils sont parfaits pour ça.
Merci pour la réponse, je vais me tourner dans cette direction !

Konolol

Re-bonjour,

J'ai donc récupéré des PC817 de chez sharp et fait 2-3 essais non concluants et je cherche donc une solution ! :)

Voilà mon montage actuel:

http://prntscr.com/bmngh9

Mais ça ne fonctionne pas (j'ai pu (certainement) mal comprendre le fonctionnement de l'optocoupleur vu mes capacités médiocres en électronique) cependant le montage fonctionne avec une LED sur un simple circuit 3.3v

Si quelqu'un à une idée, je suis preneur !

Merci !

cbrandt

#4
Jun 30, 2016, 03:26 pm Last Edit: Jun 30, 2016, 03:27 pm by cbrandt
Le branchement à l'air bon, tu as mis une resistance entre la sortie gpio de l'arduino et l'entrée de l'optocoupleur ? Environ 200 ohms devraient aller si l'arduino est en 5V… (100 ohms si tu est en 3,3V) - si mes calculs sont justes, à confirmer !

Je te proposais de tester avec juste un bouton poussoir + une résistance d'un côté de l'optocoupleur et une led + une résistance de l'autre côté, mais tu l'as déjà fait.

Et dans le code arduino ? Tu as mis la sortie GPIO à HIGH pendant combien de temps ?

Edit:  côté TV si tu court-circuites les contacts du bouton poussoir avec un bout de fil, est-ce que ça marche ?

Konolol

Bonjour, merci pour la réponse !

En fait le problème était tout simple, trop grosse resistance, j'étais parti sur les 200ohm, après un passage en 100 tout fonctionne nickel (j'ai aussi eu un coupleur défectueux apparemment)

Voila le résultat:

http://prntscr.com/bn8m90
http://prntscr.com/bn8mpi

J'ai plus qu'a faire un circuit imprimé qui ressemble à quelque chose et à le mettre à l'interieur !

En tout cas, merci pour ton aide cbrandt !

Go Up