Go Down

Topic: Arduino Builder – utility for viewing, building and uploading Arduino sketch (Read 71258 times) previous topic - next topic


Code viewer is added in 0.8.0 and the GUI version has been renamed from Arduino Uploader to Arduino Builder as it is no longer an uploader alone.


Code viewer is added in 0.8.0 and the GUI version has been renamed from Arduino Uploader to Arduino Builder as it is no longer an uploader alone.

hello sir,

this is having a bug when ArduinoBuilder-0.8.3 is used.

GUI and a hex file is able to burn to Nano3.0 correctly, PDE or INO is either no provided and no used.

however, we want simply and further user isolation and more easy, used the ArduinoUploader.exe command line tool alone, and also provided a hex file only, but it does not work.

followings command lines are not working at all,

ArduinoUploader test.hex 7 COM4
ArduinoUploader test 7 COM4

PC, Win7 64bit, ArduinoBuilder-0.8.3

would you please help to check  what was wrong with our command line.

best regards,


Hi stanleyhuang,
Is it hard to add support for other processors and pinout variants?
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.


Whenever I try to run Arduino Builder I keep getting the window below. Any idea ho to overcome this?
Don't PM me for help as I will ignore it.


This is an awesome tool!
However, is it possible to change the directory for the libraries but still include the standard arduino libraries? Pretty much multi-folder scanning for libraries. I (and probably everyone else) hold their libraries the folder that the Arduino IDE provides. It would be nice if as well as scanning the libraries folder inside the Arduino Builder folder, it could also scan one selected by the user and then save that preference. I tried creating a symbolic link to my arduino libraries folder inside of the library folder for Arduino Builder, but it failed.

Windows 8 32-bit (Works perfectly!)
Arduino Mega 2560 R3


From my experience with windows, this means exactly what it says. Try using Arduino Builder with no internet on your computer (disable WiFi and unplug the ethernet). You can try clicking the "refresh page" link. Lastly, you should try re-downloading Arduino Builder and putting it somewhere else on your machine. Is your computer fully updated (Windows Update)? Are you using the most recent version of Internet Explorer? Is your antivirus/firewall blocking the connection? Speaking of which: what is your antivirus program? Is there anything in its log saying it blocked Arduino Builder? Have you restarted your computer?

What this definitely means is that Arduino Builder somehow relies on the internet to run. Personally, I think that is a major problem in the application. Try everything above.


This is a great program Stanley.  Just what I have been looking for.
Is there any chance of adding support for the Lilypad Leonardo?


I have just downloaded ArduinoBuilder and it crashes as soon as I click build only.  No error messages - it just disappears


Thank you, this is quite nice. I am running version 0.8.9, and I am enjoying using it.
Lots of good stuff, I love that I can have multiple Arduinos and download to each of them fairly quickly.

Here are some nice to haves:
1) be able to remember the baud rate.
2) re-sizable window.
3) multiple terminals so I can see and interact with more than one Arduino.

Keep up the good work,
Thank You



I just tried to compile my sketch using this builder for the first time, and all I
get is:

The title bar    : "Error occurred during compilation (Error code:-"
The log window: "Error compiling source code."

Is there any way to actually get some useful information on the error?

PC: Windows 8.1
Arduino Builder version 0.9.0


I'd like to use this software to enhance mine, Blockly@rduino, but it always crash !
Rather strange, when I try to compile Firmata.ino ArduinoBluider closes. On W8.1x64 nor than on W2012x64.

Could tell us how to make it work.



Could tell us how to make it work.
Looks like you need a time machine to take you back to 2013

Two or three hours spent thinking and reading documentation solves most programming problems.


Hello, I really like your software.
I have a dell 6400 inspiron laptop and a acer aspire one netbook both with windows 7 installed.
Arduino Builder works great with the dell and the main window of the software displays always 2 com port to be selected for hex upload.
I can easily upload hex files on my feather 32u (selecting leonardo board) through the dell.
With the Acer I have only 1 com port and always the "no new port found" error.
Could you please help me understand why this happens ?


I have installed Arduino Builder ., but my schetches will not run.  Builder is not finding the libraries.  Where should the libraries be?  Or perhapse a better question,  where should I install Builder or how do I point Builder to the libraries.

Go Up