Go Down

Topic: [Solved] Sending Serial Data between Esplora and Uno (Read 2121 times) previous topic - next topic

runaway_pancake

If you're using my INOs, unmodified, then it's the wiring.
Please confirm that you've verified the serial out of the Esplora with the LED test.
"Who is like unto the beast? who is able to make war with him?"
When all else fails, check your wiring!

chummer1010

If you're using my INOs, unmodified, then it's the wiring.
Please confirm that you've verified the serial out of the Esplora with the LED test.
yes, it passes the LED test.
#include <signature.h>

runaway_pancake

Well, I'll wait for your pics, or video, so long as things can be scrutinized.
If you need a youtube, I can manage that, too.  ( I don't have a tripod or a cameraman though. )
"Who is like unto the beast? who is able to make war with him?"
When all else fails, check your wiring!

chummer1010

Thank you so much for helping me to this point... I have a video uploading now.
#include <signature.h>

runaway_pancake

I was wondering why my Uno 'L' LED was so dim.
It's because there's a mistake in the pinMode (chummerrx) - it should be pinMode(Lpin,OUTPUT);
(I wrote LOW instead of OUTPUT - it's much better with 'OUTPUT'!)
:smiley-mr-green:
"Who is like unto the beast? who is able to make war with him?"
When all else fails, check your wiring!

chummer1010

I made that change, still no luck. I made a video, this is before the change - https://youtu.be/hnazgOnk0wg
#include <signature.h>

chummer1010

I'll upload a clearer photo as well. One moment
#include <signature.h>

chummer1010

#37
Jul 03, 2016, 04:55 am Last Edit: Jul 03, 2016, 04:57 am by chummer1010


#include <signature.h>

runaway_pancake

#38
Jul 03, 2016, 05:07 am Last Edit: Jul 03, 2016, 05:11 am by Runaway Pancake
Your resistor is brown-black-yellow looks like?
If so, that is 100k.  Might be too much.
Brown-black-orange is 10k, red-red-orange is 22k.

> > > (Yellow LED with no resistor - unrelated, but stop that.)
"Who is like unto the beast? who is able to make war with him?"
When all else fails, check your wiring!

chummer1010

#39
Jul 03, 2016, 05:13 am Last Edit: Jul 03, 2016, 05:14 am by chummer1010
My resistor is brown, black, orange ; it's a 10k resistor, just poor lighting

>>> regarding the led, sorry, bad habit, it's just convenient
#include <signature.h>

runaway_pancake

#40
Jul 03, 2016, 05:53 am Last Edit: Jul 03, 2016, 05:57 am by Runaway Pancake
OK, it may make no difference, but could you try it with A1 (in case anything "happened" to D3)?

> > > Hoping your jumper-dudes there are solid. I'm uploading an "unlisted" to youtube, very slow.
"Who is like unto the beast? who is able to make war with him?"
When all else fails, check your wiring!

chummer1010

#41
Jul 03, 2016, 03:10 pm Last Edit: Jul 03, 2016, 03:11 pm by chummer1010
My LED was not wired correctly  :-[

Solutions on reply 21  and 25.
#include <signature.h>

nicolopadovandev

Hi. I followed the whole thread but I'm not having results... I uploaded the files chummerx and chummerremote, connected the Esplora's TXD1 to a resistor (Brown, black, red, yellow) and then the resistor to the 3~ pin on the UNO. Then I connected a led to the 13 pin and a resistor to the ground, and the grounds of the arduinos together
The most intelligent people in the world are the ones who don't think of themselves as the most intelligent person in the world.

Go Up