Go Down

Topic: [OT] Stampa 3D per tutti ... novità, curiosità, amenità, chiacchiere varie (Read 164853 times) previous topic - next topic

PaoloP

:o  :o  :o  ... ma hai una stampante con a bordo Win10 ? ... (:smiley-twist: :smiley-twist: :smiley-twist:)
No. Rasp OS.
Probabilmente hanno fatto qualche casino ricompilando il Kernel.... poveri cantinari!!

astrobeed

Qui trovi i vari firmware per le stampanti 3Drag, tutte le versioni, e la configurazione per Slic3r.
"Piccolo" problema, le configurazioni sono per la versione 1.2, quella singolo estrusore con il filamento da 3 mm, solo per la versione big, la modifica con il carrello lungo 40 cm invece di 20 cm, c'è una configurazione per l'estrusore da 1.75 mm.
Ho fatto una prova al volo con la configurazione per la big da 1.75mm e il gcode adesso è decisamente molto meglio, non è ancora perfetto però ci siamo quasi.
Vedo se riesco a crearti una configurazione ottimale per la tua stampante partendo da questa che sto provando.
Scientia potentia est

astrobeed

No. Rasp OS.
Probabilmente hanno fatto qualche casino ricompilando il Kernel.... poveri cantinari!!
No, è un problema che hanno lamentato in molti con la Fabtotum, in pratica l'update ha fatto casini sulla SD, devi rifarla partendo dall'immagine, dovrebbe essere disponibile sul loro sito.
Scientia potentia est

menniti

Trovato in due secondi. :)
Qui trovi i vari firmware per le stampanti 3Drag, tutte le versioni, e la configurazione per Slic3r.
Adesso provo a reinstallare Repetier Host, è da un sacco di tempo che non lo uso più, e provo con la loro configurazione a generare il gcode per il cubo.

se non ricordo male io ho la 1.3, avevo preso il display grafico per la stampa in stand-alone, ora non ricordo più la questione ma allora mi dissero di usare la versione 1.0.6 altrimenti non era compatibile; siccome non l'ho mai usato in stand-alone, io sto usando la 1.6.0 o qualcosa del genere e il display lo so come inutile monitor visto che vedo comunque tutto sul PC. Altro problema che ho avuto è stata l'impossibilità di programmare la scheda madre col 2560, per aggiornare il firmware ho dovuto rispedirgliela. Se trovi anche qualcosa in merito fammi sapere, non posso stare con questa spada di Damocle.....
Comunque oggi pomeriggio gli scrivo per avere loro novità.


Quote
Ho fatto una prova al volo con la configurazione per la big da 1.75mm e il gcode adesso è decisamente molto meglio, non è ancora perfetto però ci siamo quasi.
Vedo se riesco a crearti una configurazione ottimale per la tua stampante partendo da questa che sto provando.
OK, grazie mille, posso provare tutto oggi pomeriggio, se ce la fai.

astrobeed

Intanto ho ricostruito la storia della 3Drag a doppio estrusore, come sospettavo è "figlia" della Velleman K8400, nota anche come Vertex, o meglio prende in prestito da questa l'elettronica e il firmware.
Per programmare la scheda c'è un jumper, dovrebbe chiamarsi JPROG, che isola il reset, se non lo chiudi non è possibile trasferire il codice, a meno di non premere manualmente il tasto di reset.
Attenzione che se aggiorni il firmware tocca ricaricare i parametri sulla EEPROM, si fa da Repetier Host, prima di aggiornare il firmware devi leggere il contenuto EEPROM e segnarti i vari valori, li devi reinserire a mano dopo l'update.
Ti hanno consigliato repetier host 1.0.6 perché questo fornisce Velleman per la K8400, però loro danno la configurazione per Cura e non per Repetier Host.
Sul forum di Futura Elettronica, a precisa domanda su come configurare la 3Drag a doppio estrusore è arrivata come risposta ufficiale un link alla pagina della 3Drag v1.2 e di seguire quella configurazione cambiando solo il diametro del filamento e quello dell'ugello,
Mi spiace doverlo dire ma è una risposta da peracottari, chi ha risposto non è competente e non dovrebbe rispondere ufficialmente per Futura Elettronica sul loro forum in materia stampanti 3D.
E' un dato di fatto che Futura Elettronica non fornisce nessuna configurazione di base per Slic3r relativa alla 3Drag con doppio estrusore, non danno nemmeno lo schema dell'elettronica, però questo perché essendo una scheda Velleman manca da parte loro.

Per farla breve, tocca rimboccarsi le maniche e risolvere la questione da soli, a meno che Landoni non ti manda un file di configurazione pronto, loro dovrebbero averlo.

Questione display grafico, mi ricordo di aver letto sul loro forum che avevano dei problemi col firmware, però è riferito alla loro elettronica, quella per la stampante mono estrusore, tocca capire se ci sono anche con la scheda di Velleman, sul loro sito c'è il firmware da scaricare per la Vertex nelle varie versioni, singolo/doppio estrusore, con e senza display, però non credo sia utilizzabile con la tua stampante.
Però mi pare di capire che attualmente il display ti funziona e leggi sopra le varie informazioni, questa cosa non ha nulla a che vedere con la versione di Repetier Host, è gestita in toto dal firmware, se non ti funziona la stampa standalone da SD, molto comoda, tocca capire il motivo.
Scientia potentia est

astrobeed

In allegato la configurazione Slic3r per la tua stampante, per il momento è singolo estrusore, una volta messa a punto attiviamo anche il secondo estrusore.
Installa l'ultima versione di Repetier Host, la 1.6.2, e importa il file config.ini nella configurazione di Slic3r, quando stampi assicurati di selezionare su "impostazioni stampa", "impostazioni stampante", "Estrusore 1", nel menù per lo slicing, "Slic3r_175_pla_config".

Questo è il rendering del gcode, primo layer, fatto da Repetier Host, come puoi vedere è "leggermente" diverso da quello che hai ora. :)


Scientia potentia est

menniti

Purtroppo non mi ricordo più niente, sono passati 8 mesi da quando l'ho montata e fatti i primi test; devo riprendermi le mail di quel periodo ma forse ho anche un file che allegai, oggi mi metto a cercare. La storia del jumper jprog me la ricordo ed infatti è ancora inserito sulla board, la stravaganza della situazione era che apparentemente caricava il firmware ma di fatto non cambiava nulla.
I parametri di configurazione della stampante me li sono ricavati da solo e sono perfetti, perché io ho anche sostituito i driver a 16 passi con quelli a 32, so come si fa quell'operazione e ho tutto segnato su un file, proprio nel caso dovessi perderli.
A Landoni ho scritto, gli ho detto di mettermi in contatto con il loro esperto in materia, tra poco dovrebbe farmi sapere qualcosa.
Intanto procedo con le tue istruzioni. Grazie.

PaoloP

A Landoni ho scritto, gli ho detto di mettermi in contatto con il loro esperto in materia, tra poco dovrebbe farmi sapere qualcosa.
Adesso ti passano il numero di telefono di Astro.  :smiley-mr-green:  :smiley-mr-green:  :smiley-mr-green:

astrobeed

Non ci posso credere, pure su thingiverse è apparso un modello della terra piatta, l'ultima moda del mondo complottista. :D

Scientia potentia est

gpb01

Non ci posso credere, pure su thingiverse è apparso un modello della terra piatta, l'ultima moda del mondo complottista. :D
     

Guglielmo
Search is Your friend ... or I am Your enemy !

Etemenanki

... c'e' anche l'inferno nel lato inferiore ? ... come nelle vecchie incisioni del medioevo ? ... :D :D :D
"Sopravvivere" e' attualmente l'unico lusso che la maggior parte dei Cittadini italiani,
sia pure a costo di enormi sacrifici, riesce ancora a permettersi.

menniti

In allegato la configurazione Slic3r per la tua stampante, per il momento è singolo estrusore, una volta messa a punto attiviamo anche il secondo estrusore.
Installa l'ultima versione di Repetier Host, la 1.6.2, e importa il file config.ini nella configurazione di Slic3r, quando stampi assicurati di selezionare su "impostazioni stampa", "impostazioni stampante", "Estrusore 1", nel menù per lo slicing, "Slic3r_175_pla_config".

Questo è il rendering del gcode, primo layer, fatto da Repetier Host, come puoi vedere è "leggermente" diverso da quello che hai ora. :)
Sì, la risoluzione è decisamente migliorata, comunque riguardo il parametro "velocità" che si trova nella maschera "controllo manuale" quando inizia il riempimento "veloce" inevitabilmente devo portarlo da 100 a 60 altrimenti mi perde la posizione x e comincia a stampare sempre più a destra (sto ristampando le morse); questa volta mi ha fregato per un paio di layer ma poi col solito trucco pausa/x/riprendi è ripartito alla perfezione e, come l'altra sera non perde più un colpo.
Ora devo vedere la tenuta sul piatto, perché io avevo messo la ventolina al 100% a partire dal 2° layer, mentre in questa configurazione parte dal 3° layer al 39% ed al 12° è ancora alla stessa velocità.
Quindi io direi che i parametri vanno bene, solo che, se è  possibile, vorrei lasciare la velocità attuale per la stampa di riempimento pieno, mentre dovrei ridurla del 40% solo quando fa i riempimenti veloci (il nido d'ape o il rectilinear per capirci). In questo modo posso ottimizzare la stampa e recuperare qualcosa sui tempi, mentre se devo agire manualmente o imposto tutto al -40% oppure devo stare a seguire la stampa per lavorare manualmente in base al layer, ma è cosa da pazzi. C'è questa possibilità?

EDIT: Ho verificato che la questione dell'LCD grafico era stata superata quando mi hanno aggiornato loro il firmware della scheda, infatti i parametri che leggo sono identici a quelli del PC.

EDIT2: sono al 30° layer e c'è un leggerissimo warping nella parte posteriore del pezzo posteriore che però sta aumentando, secondo me devo aumentare la velocità della ventola e stampare il 1° layer a 195° come in precedenza. Tornando la discorso velocità in questa fase c'è il riempimento pieno ed infatti è di una lentezza esasperante.

EDIT3: leggendo i TS che avete linkato nei giorni scorsi ho trovato che le tre possibili causa di slittamento dei layer sono: a) stampa troppo veloce, ridurre del 50% (io l'ho ridotta del 40% ma va benissimo lo stesso); b) viti di ancoraggio delle pulegge tiracinghia ai motori allentate; c) cinghia dell'asse interessato (x nel mio caso) troppo lenta o che urta da qualche parte.

EDIT4: ho teso la cinghia "x" effettivamente era un poco lenta, le viti delle pulegge erano ok, ora ho impostato la velocità fan 100% dal 2° layer, ho tolto il blu tape, ho impostato la velocità infill a 45 invece di 80, sto stampando uno dei tanti accessori per il rotolo PLA. Vi aggiorno fra 3 ore e mezza se va tutto bene altrimenti prima....

EDIT5: Niente da fare, due tentativi diretti sul vetro, uno con ventola al 100% e l'altro con i parametri di Astro; il pezzo si alza dal lato più vicino alla ventola e poi si distacca completamente. Ora faccio una nuova prova col blu tape e la ventola gestita in automatico

@ Guglielmo: vorrei sapere se sto violando qualcosa illustrando passo passo tutte le prove e riflessioni che faccio, e con i vari EDIT che, se non interviene nessun altro, mi sembrano più ordinati di altrettanti post consecutivi.

speedyant

... c'e' anche l'inferno nel lato inferiore ? ... come nelle vecchie incisioni del medioevo ? ... :D :D :D
Per quella versione ci vuole l'apposito plug-in "divinacommedia" :D
Le peripezie del buon Michele dimostrano quanto sia tuttora "per pochi" la stampa 3d.
Seguo con interesse.

gpb01

Le peripezie del buon Michele dimostrano quanto sia tuttora "per pochi" la stampa 3d.
... cosa che non smetto mai di ribadire, alla faccia di tutta la pubblicità e le "balle" sulla semplicità d'uso.

In realtà, siamo ancora al livello che ... o sei uno "smanettone" o e meglio che rinunci da subito. Vedremo il futuro cosa ci riserverà ::)

Guglielmo
Search is Your friend ... or I am Your enemy !

astrobeed

Speriamo che arriva presto questo, così non devo più cucinare. :D

Scientia potentia est

Go Up