Go Down

Topic: Trouble using 4 moisture sensors in parallel on A0-A3 input pins on Uno (Read 1 time) previous topic - next topic

Wawa

Shorting a sensor should result in an analogue value of ZERO.
Check your wiring.
Ground to the first three sensors could be missing/broken.
Leo..

jproehl

Leo:

  That's one thing I do understand, that's why I've tested this by shorting out the arms of the sensors and saw that only sensor #4 is behaving normally. I did a continuity check with my multimeter and the ground at the YL-38 interface board for sensor #4 is connected to the grounds for all of the other 3 interface boards.

  I began to wonder if the UNO or the analog pin choice were the problem, so I tried it on a MEGA2560 and shifted the pins to A8, A9, A10 and A11 and changed my code and still get the same behavior.
 
  In addition, previously I went through the exercise of switching the YL-69 sensors around on the YL-38 interface boards as well as switching around the YL-38 interface boards and have always found that the board/sensor combo connected to analog pin A3 always works and none of the others do.

  By the way, in doing the rewiring to allow me to sequentially power the sensors, I even replaced the 4 pin header board that connects the sensors to the Arduino.  It behaves the same way with the new header board as before.

None of these debugging tests uncovers the problem.  I'm totally mystified.

Jeff

jproehl

Leo:

  I finally figured it out! I did have continuity problems, but not with my grounds.  In the wiring harness from the sensor pin, through the 4 pin header to the analog pins, the 1st 3 sensor lines were not continuous. Somehow the wires got fried.  Interestingly, the discontinuous sections were not the same for the three wires. So, I need to remake my wire harness and confirm that all is good and I should be okay.

Thanks a bunch for your help, I would not have solved this without it!

Take care,
Jeff

Go Up