Go Down

Topic: USB communication failed (Read 1 time) previous topic - next topic


I have two MKR1000 for testing my sketches using the wifi1010 library.

Due to an unknown problem, I lost the control to the MKR1000 over the USB connection (bricked?). No chance to put the MKR in an controllable state with the Arduino IDE. Then I disconnect the MKR from the USB port an reconnect again. This was OK for some times. But now, the MKR isn't reachable over USB. The Windows Device Manager says: «Unknown USB Device».

Then I read about the double click on the reset button. I made a double click, and the device manager reports the MKR is in bootloader mode. ("Genuino MKR1000 bootloader (COM9)"

My second MKR1000 has exactly the same issue.

Somebody have an idea ?



Jul 27, 2016, 11:16 pm Last Edit: Jul 27, 2016, 11:18 pm by Ballscrewbob
Its a known issue.

The  "double tap" is the only fix offered.

Once in "bootloader" mode you can upload via that port.

Also using an external serial monitor is known to wake up a catatonic MKR too (the IDE one sometimes works for this but not always).

They are not "bricked" just buggy as h3ll on occasion.
They are also quite finicky about the supply voltage offered by some USB ports.

Mine seems better since I added the test arm URL to the additional boards manager in preferences.
Don't know if its the fix but not had many issues since.



Also try using Sandeepmistry new version of the WiFi101 library too.
It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.


I had a similar issue if not the same and support solved my issue with this...

The foam that the MRK1000 boards is so awesome I didn't want to separate it from the board while I programed them. The problem is the foam packing material is slightly conductive to protect the board from magnetic damage. This means of course that you have to REMOVE the board from its foam-home before connecting the micro USB to program it.

Thank you support!

Details of my symptoms: I was able to connect (my Windows/OSX and Linux PCs - yes I tested all of them) all only very infrequently could see the device once it was plugged in. I noticed the secondary green led was weakly flaky and not very confident inspiring so I THOUGHT it may be a loose microUSB connection on the board (since I tried multiple cables as well). Until I tried the second MRK1000 bought at the same time doing the same exact thing. So I reached out to support who solved my issue promptly.

Go Up