Go Down

Topic: Motore Nema 23 - driver A4988 associazione fili (Read 616 times) previous topic - next topic

_pier

Ciao a tutti,
come da oggetto sono in possesso di 3 motori stepper di cui non conosco le specifiche. Do' per scontato che siano nema 23 per via della loro dimensione (2,3 pollici), da questi stepper escono 6 fili.
Non avendo alcun datasheet ho provveduto, tester alla mano, a stilare la tabella in immagine.

Detto ciò volevo comandare i tre motori stepper con arduino + CNC Shield v.3.0 + i driver A4988.

Ho carico grbl v 0.9 in arduino e con universal GCode sender ho fatto un tentativo per comandare il motore (ho provato con uno solo), il tutto alimentato da trasformatore 12v - 10A collegato alla 3d Shield

Ho collegato il motore al driver nel modo in figura: giallo-blu-rosso-verde. Avvio UniversalGCodeSender, il motorino si muoveva! Ho cambiato solo l'impostazione relativa all'accelerazione ed ero riuscito a farlo girare!

Oggi, nel tentativo di aggiungere il secondo motore (quindi driver + collegamento come motore precedente), non ottengo più nessun risultato, se non un leggere surriscaldamento di entrambi i motori e un piccolissimo scattino all'avvio di ogni comando.

Cosa può essere? c'è da lavorare sulle impostazioni di grbl? se si, in che modo e perchè al primo tentativo non avevo avuto questa necessità?

Grazie a tutti,
Pier

PaoloP


pictux

Aggiungo: la cnc shield che usi è compatibile con grbl?
Ovvero: hai verificato se la configurazione dei pin su grbl corrisponde alla piedinatura sulla shield?

Go Up