Go Down

Topic: IDE no longer works after preferences JSON add for ESP8266 (Read 1 time) previous topic - next topic

svangent

Working with ESP8266, had issue with Proxy here at work, once I fixed proxy, JSON link added in pref started working, I shut down and restarted IDE, shows splashscreen but will not launch.

I have uninstalled, reinstalled dozen times, deleted all directories associated with Arduino.  NO change.  IDE will not work (HOWEVER, version 10.0.5R2 still works).

I am a rookie Arduino user, below is output from Arduino_debug;  Any help is appreciated.

*************************************************************

C:\Program Files (x86)\Arduino>arduino_debug
Picked up _JAVA_OPTIONS: -Djava.net.preferIPv4Stack=true
Loading configuration...
Initializing packages...
java.io.CharConversionException: Invalid UTF-32 character 0x90fd11(above 10ffff)
  at char #1543, byte #6175)
        at com.fasterxml.jackson.core.io.UTF32Reader.reportInvalid(UTF32Reader.j
ava:189)
        at com.fasterxml.jackson.core.io.UTF32Reader.read(UTF32Reader.java:150)
        at com.fasterxml.jackson.core.json.ReaderBasedJsonParser.loadMore(Reader
BasedJsonParser.java:153)
        at com.fasterxml.jackson.core.json.ReaderBasedJsonParser._skipWSOrEnd(Re
aderBasedJsonParser.java:2017)
        at com.fasterxml.jackson.core.json.ReaderBasedJsonParser.nextToken(Reade
rBasedJsonParser.java:577)
        at com.fasterxml.jackson.databind.ObjectMapper._initForReading(ObjectMap
per.java:3776)
        at com.fasterxml.jackson.databind.ObjectMapper._readMapAndClose(ObjectMa
pper.java:3721)
        at com.fasterxml.jackson.databind.ObjectMapper.readValue(ObjectMapper.ja
va:2796)
        at cc.arduino.contributions.packages.ContributionsIndexer.parseIndex(Con
tributionsIndexer.java:180)
        at cc.arduino.contributions.packages.ContributionsIndexer.parseIndex(Con
tributionsIndexer.java:93)
        at processing.app.BaseNoGui.initPackages(BaseNoGui.java:602)
        at processing.app.Base.<init>(Base.java:296)
        at processing.app.Base.guardedMain(Base.java:223)
        at processing.app.Base.main(Base.java:136)

C:\Program Files (x86)\Arduino>

svangent

I have tried several other things I have seen posted.  Appears I am not the only person this happens to.  This is crazy!  I have never seen a piece of software that cannot recover from crash with a uninstall, delete all trace  and reinstall.

I  have no idea what to try at this point other than wipe my OS and reload, which I find ridiculous. 

ballscrewbob

Best bet for using ESP boards is 1.6.5 r5 zipped version.

Some ESP boards work for me under 1.6.9 but anything above that has issues and not just with ESP's if you took the time to read the amount of negative (but true) posts about 1.6.10.

Get a copy of 1.6.5 and unzip it and set up a shortcut to it.
Works every time here on a variety of ESP's

Set up 1.6.9 for Arduinos only.


It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

svangent

Well, good news and bad news; 

went to 1.6.4 since 1.6.5 does not support proxy internally;  I go this error;

Illegal character ((CTRL-CHAR, code 0)) :  only regular white space allowed between tokens at Blah blah blah...  I can add detail on request.

After, 1.6.4 will also no longer start up.  So this is kill each in succession.

I double checked that I did not put any white space in entery.

pref file contents;

board=uno
boardsmanager.additional.urls=http://arduino.esp8266.com/stable/package_esp8266com_index.json
build.verbose=false
build.warn_data_percentage=75
compiler.warning_level=none
console=true
console.auto_clear=true
console.error.file=stderr.txt
console.length=500
console.lines=4
console.output.file=stdout.txt
editor.antialias=true
editor.caret.blink=true
editor.code_folding=false
editor.divider.size=2
editor.external=false
editor.font=Monospaced,plain,12
editor.indent=true
editor.invalid=false
editor.keys.alternative_cut_copy_paste=true
editor.keys.home_and_end_travel_far=false
editor.keys.shift_backspace_is_delete=true
editor.languages.current=
editor.linenumbers=false
editor.save_on_verify=true
editor.tabs.expand=true
editor.tabs.size=2
editor.update_extension=true
editor.window.height.default=600
editor.window.height.min=290
editor.window.width.default=500
editor.window.width.min=400
export.applet.separate_jar_files=false
export.application.fullscreen=false
export.application.platform=true
export.application.stop=true
export.delete_target_folder=true
last.folder=C:\Users\myname\Documents\Arduino\EPS_STICK 2\ESPixelStick-master\ESPixelStick\ESPixelStick.ino
last.ide.1.6.4.daterun=1471399917
last.ide.1.6.4.hardwarepath=C:\Users\myname\Documents\Arduino 1_6_4\arduino-1.6.4\hardware
last.ide.1.6.5.daterun=1471399387
last.ide.1.6.5.hardwarepath=C:\Users\myname\Documents\Arduino 1_6_5_r5\arduino-1.6.5-r5\hardware
last.screen.height=1200
last.screen.width=1920
last.sketch.count=0
last.sketch0.location=760,350,500,600,400
last.sketch0.path=C:\Users\myname\Documents\Arduino\EPS_STICK 2\ESPixelStick-master\ESPixelStick\ESPixelStick.ino
platform.auto_file_type_associations=true
preproc.color_datatype=true
preproc.enhanced_casting=true
preproc.imports.list=java.applet.*,java.awt.Dimension,java.awt.Frame,java.awt.event.MouseEvent,java.awt.event.KeyEvent,java.awt.event.FocusEvent,java.awt.Image,java.io.*,java.net.*,java.text.*,java.util.*,java.util.zip.*,java.util.regex.*
preproc.output_parse_tree=false
preproc.save_build_files=false
preproc.substitute_floats=true
preproc.substitute_unicode=true
preproc.web_colors=true
programmer=arduino:avrispmkii
proxy.http.port=REMOVE FROM THIS THREAD FOR SECURITY REASONS
proxy.http.server= REMOVE FROM THIS THREAD FOR SECURITY REASONS
proxy.https.server=
proxy.password=
proxy.user=
recent.sketches=C:\Users\myname\Documents\Arduino\EPS_STICK 2\ESPixelStick-master\ESPixelStick\ESPixelStick.ino,
run.display=1
run.options=
run.options.memory=false
run.options.memory.initial=64
run.options.memory.maximum=256
run.present.bgcolor=#666666
run.present.exclusive=false
run.present.stop.color=#cccccc
serial.databits=8
serial.debug_rate=9600
serial.parity=N
serial.port=COM1
serial.stopbits=1
sketchbook.path=C:\Users\myname\Documents\Arduino
software=ARDUINO
target_package=arduino
target_platform=avr
update.check=true
update.id=-4168508586847959386
upload.using=bootloader
upload.verbose=false
upload.verify=true



ballscrewbob

#4
Aug 17, 2016, 05:07 am Last Edit: Aug 17, 2016, 05:22 am by Ballscrewbob Reason: extra info
Had not noticed you were using a proxy.
Use VPN's myself with no issues.

Yes please include some verbose output.

Did you run 1.6.4 from an UNZIP location (not installed) ?

Also what sort of clean up have you been doing after an un-install of an IDE ?
Just using the regular uninstaller leaves a folder behind in one of two locations depending on the IDE installed.

Look up some of "pert" posts he often mentions them and they often fix issues.

EDIT here are the locations I got from Pert.


On Windows:
Arduino IDE 1.6.5r5 and previous:
C:\Users\(username)\AppData\Roaming\Arduino15
Arduino IDE 1.6.6 and later:
C:\Users\(username)\AppData\Local\Arduino15

I also move my sketches location away from my documents folder as I hav had a couple of issues in the past.

I also use CCLEANER after an uninstall then WISE registry cleaner as well to dig out any remnants of a past IDE
It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

svangent

Great news, hidden locations did in fact harbor hidden files.  Once folders were deleted, version boots.

Proxy is working but took about 5 tries to get it to sync up.  Not sure what this is about.

Anyway, thanks for help.

Go Up