Go Down

Topic: Arduino UNO R3 and Ethernet Shield W5100 - compatibility issues? (Read 1 time) previous topic - next topic

nikolenkoa

Dear friends,

I have the following boards:
1. Arduino UNO R3
2. Ethernet shield with WIZNET W5100

Arduino alone is working fine, but one I attach Ethernet shield on it, it stops responding to any attempt to upload a sketch, giving the following error:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00


there is a marl on the ethernet shield "MEGA compatible", does this mean that it will not work on UNO or it's a problem with specific board?

thanks in advance...

pert

Mega compatible just means it uses the ICSP header on the board to connect the SPI lines instead of using pins 11/12/13, which are SPI on the Uno but not on the Mega. So a "Mega compatible" shield will work on both Uno and Mega.

nikolenkoa

"Mega compatible" shield will work on both Uno and Mega.

well, in this case it's a shield problem...

anyone else using the same shield, or all of them are based on W5100?

pert

I use a W5100 based, Mega compatible shield all the time with an Uno. It works fine. That doesn't necessarily mean that it's the exact same shield though. Many different companies make them. In most cases these days they're made by some random Chinese company. Mine has no shield manufacture branding on it at all. WIZnet is just the manufacturer of the ethernet controller chip on there. Most likely they didn't make your shield. Many people get confused by the "Han Run" sticker on the Ethernet jack thinking it's the shield brand but that's only the manufacturer of the jack, not the shield.

nikolenkoa

Yep, I have something similar too, no specific marking on the shield.
what I've noticed as well - LED13 is not blinking after restart, when the shield is connected, so I ordered another one from different supplier, let's see..

anton1o

what I've noticed as well - LED13 is not blinking after restart, when the shield is connected, so I ordered another one from different supplier, let's see..
which supplier sends not operational shield to You? 

Go Up