Go Down

Topic: YunFirstConfig on Mega (Read 1 time) previous topic - next topic



I am trying to use a Yun shield on my Arduino Mega 2560. Already when I try to compile the YunFirstConfig sketch I get the error message:

'SERIAL_PORT_USBVIRTUAL' was not declared in this scope

What's wrong?



I solved it but the blood pressure is still a bit high. I made a rant about the Yun board that I also own on this forum and also in this case things worked out in the end without me knowing why. Enough patience and restarts was the trick.

First, of course YunFirstConfig does not work on a Mega or a Uno. It is not clearly stated on the product but the "Getting Started" link tells what to do instead. I would expect many people to purchase a shield to spice up good ole Uno with some IoT capabilities and to in this case write that it is easy to configure "...thanks to the Yún Web Panel and the dedicated ''YunFirstConfig'' sketch" without clearly mentioning that it does not work like this on the "bread and butter" product is definitely misleading.

So then I only had to find the Yun among my wifi networks and get a long with it. The problem was that no Yun was visible, the shield itself had only a green LED lit up. So tired to do something about it. Can it help to press the Config Reset button for 30 seconds? Does the Mega disturb the process in any way, was the YunFirstConfig still loaded and disturbed the linux board? Load the "blink" sketch. After every step I leave it on for several hours. I ended up pressing the Config Reset not for 30 seconds but until the thumb hurt and left it on again hoping that more LEDs will shine if I stare at the d**n shield.

So I was about to write a rant about all this (or maybe a cry for help, is there any other way to reach my precious little Yun?) when all of sudden, a blue LED! And it happened as I for the zillionth time disconnected and connected the Mega to the USB. And it lit up quite immediately after power on.

So now this little Norwegian Blue shield is working. I thin I can load sketches to the Mega over wifi etc.


Thanks for sticking with it.

I agree it can be a bit of a steep learning curve after other boards.
My lack  of hair is a testament to that ;)

If you ever have to UPGRADE it be prepared for some more fun and games.
Most people have better success getting up and running by using Ethernet cables for the first few runs at the YUN.

Get the Monty Python pun too  :D
It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

Go Up