Go Down

Topic: 1.6.11 - Invalid version found: 1.04 [solved] (Read 6992 times) previous topic - next topic

bHogan

Sep 10, 2016, 10:01 pm Last Edit: Sep 13, 2016, 05:12 pm by bHogan
Hi,

What do I have to do to get rid of "Invalid version found: 1.04" in IDE 1.6.11?
I have many of these warnings. (I assume they are just warnings.)

I guess it has something to do with the libs - "category=" maybe ?
I have a lot of libs. Any way to ID which?

What does 1.o4 refer to?

Thanks,
John
"Data is not information, information is not knowledge, knowledge is not understanding, understanding is not wisdom."
~ Clifford Stoll

pert

There's a library installed that has the line
Code: [Select]
version=1.04
in its library.properties file. It's just a warning. The only problem it will cause is for the Arduino IDE knowing if there's a newer version available. It's very annoying to always get these warnings though so worth fixing. Unfortunately the Arduino developers didn't bother to make the warning say which library it is. One way you can find it is:
  • Sketch > Include Library > Manage Libraries > Type: Installed
  • Scroll through the list of installed libraries and note any that say "Version unknown".
  • Click the "Close" button.
  • File > Examples > {library without version name} > pick any example
  • Sketch > Show sketch folder
  • This will open the examples subfolder of the library folder. Navigate to the root folder of the library folder.
  • Open the file library.properties, if the library doesn't have a library.properties file then it's not the one causing the warning.
  • Once you find the file with the invalid version change it to "version=1.4".
  • Save the file
  • Please let me know which library(s) are causing the warning and I'll see if I can get them fixed.

bHogan

Thanks for that well written answer pert.
Using that technique I did find some libs with that version (Adafruit BME280 and ST7735) however I don't think they are the problem/

I have many libs under my sketchbook, most not installed with the lib manager.

I think I'll just have to live with it.

John
"Data is not information, information is not knowledge, knowledge is not understanding, understanding is not wisdom."
~ Clifford Stoll

pert

Yes, I checked the online versions of those libraries and they are 1.0.4 instead of 1.04. 1.0.4 is a valid version so if that's the version number they have on your system they are not the cause of the warning.

SteveBurton

In my case, the library at fault was 'UIPEthernet'

Hope that helps someone.

Steve.

pert

I suspect that's the same library that caused the warning for bHogan. Thanks!

There is a branch of that library specifically for Arduino IDE 1.5 and later: https://github.com/ntruchsess/arduino_uip/tree/Arduino_1.5.x. It has a valid version and also has the "Invalid Category" warning fixed. Note that the author has forgotten to update the version value in library.properties. The last release of that branch is actually at 1.59 instead of the 1.50 stated in library.properties.

bHogan

#6
Sep 13, 2016, 05:08 pm Last Edit: Sep 13, 2016, 05:11 pm by bHogan
Bingo!

That was it - UIPEthernet.

Thanks to you both. I appreciate your follow-through.

All the best,
John
"Data is not information, information is not knowledge, knowledge is not understanding, understanding is not wisdom."
~ Clifford Stoll

Ed1960

In my case, the library at fault was 'UIPEthernet'

Hope that helps someone.

Steve.
yes that helped alot. I was following the method described but the UIPEthernet didnt show up at all. I knew I had it installed though but would never have guessed that was the one without yr tip

insippo

Library UIPEthernet in file library.properies line 9. version=1.04 need change to: version=1.0.4 One dot only.

tigars

After reading your comments and knowing that it was only text to correct, I used a text editor with search and replace in the libraries folder and everything changed correctly. However, I do not know which libraries is involved.

pert

The library is uipethernet and the problem is that you have the wrong version installed. Please replace your currently installed version with the one from this branch:
https://github.com/ntruchsess/arduino_uip/tree/Arduino_1.5.x

cassyarduino

#11
Mar 09, 2017, 09:22 am Last Edit: Mar 09, 2017, 09:35 am by cassyarduino
Hi All!

You can download UIPEthernet library from https://github.com/UIPEthernet/UIPEthernet
This is working with atmel MCU-s, stm32 devices and ESP8266 and many more.

Best Regards

pert

Hi,

I Have the same problem with PWM library --> "PWM version unknown INSTALLED"
i installed the library correctly from the following link:
https://code.google.com/archive/p/arduino-pwm-frequency-library/downloads

is it possible that it is related to the IDE version? I'm using the newest Arduino 1.8.1
what could i do to solve it?

Tanks,
Lior
DON'T CROSS-POST!!!
DON'T THREADJACK!!!
Your problem has absolutely nothing to do with the subject of this thread. I'm going to respond on your other post:
http://forum.arduino.cc/index.php?topic=117425.msg3183154#msg3183154

adjplante@gmail.com

If you have a Linux or mac os x based system you can use the following command to find all recurrences of version=1.04 in your code :

 find . -type f -exec grep -l version=1.04 {} \;

Go Up