Go Down

Topic: Error with old Arduino releases (Read 2607 times) previous topic - next topic

ScrambledEggs

Hello,

I'm trying to upload Marlin to my Arduino mega.

The Marlin wiki page says to use 1.0.5 or 1.0.6

When trying to compile using any old release I keep getting the same error message saying:

'Versions of Arduino IDE prior to 1.6.0 are no longer supported, please update your toolkit.'

I thought I'd try using the latest release but it hasn't worked - I just get a blank screen.

How can I use the old releases?

Thanks

pert

How can I use the old releases?
You probably need to use an old version of the Marlin firmware but I would recommend figuring out how to use the latest stable Marlin release instead. My guess is the wiki(which you didn't provide a link to) you're looking at just hasn't been updated for a long time. If you look at the installation instructions in the official Marlin firmware repository wiki at https://github.com/MarlinFirmware/Marlin/wiki/DNE-Setup they say:
Quote
Obtain the latest non-beta Arduino software IDE / toolset from the Arduino website.
Note they don't say anything about using some IDE version that's been obsolete for years, they say use the latest version of the Arduino IDE.

So we know that one part of that wiki you're using is bad information, this means there's probably other bad information also so try following all the instructions from the wiki I provided a link to instead. There are thousands of people using Marlin with the latest IDE version, I'm sure you can get it working for you too.

ScrambledEggs

Thanks, I'll try again following the wiki you posted.

I was following the reprapwiki page ....http://reprap.org/wiki/Marlin


I already have a laser cutter running Marlin and didn't have an issue last time so I'm not sure what's changed.

ScrambledEggs

It was an old version of Marlin I was trying to use but it worked for my laser cutter a few months back.


I've followed the wiki you posted and I've managed to upload Marlin 1.0.2-1 using Arduino 1.6.11.


I'm still getting a blank screen. It lights up but nothing else, no response from buttons etc.


pert

Marlin has a lot of different configuration settings. You have to make sure they are all correct for your hardware.

ScrambledEggs

This is the hardware I have...eBay link

Which is the same hardware I used for my laser cutter.


I don't remember having to configure Marlin to work with that hardware previously. Has there been a change to Marlin recently that now requires a different configuration?

ScrambledEggs

By using Marlin-RC rather than 1.0.2-1 I've managed to get the LCD working.

I'm now having problems with defining the Board type as I don't have a heated bed I want to select BOARD_RAMPS_14_EFF but then I get the error below when compiling:

Code: [Select]
Arduino: 1.6.11 (Windows 10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

sketch\temperature.cpp: In static member function 'static void Temperature::manage_heater()':

temperature.cpp:800: error: 'WRITE_HEATER_BED' was not declared in this scope

         WRITE_HEATER_BED(LOW);

                             ^

exit status 1
'WRITE_HEATER_BED' was not declared in this scope

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.


If I leave the motherboard as BOARD_RAMPS_14_EFB it will compile and upload but I get an error on the LCD saying:

Err: MINTEMP BED

I guess I need to comment out part of the configuration.h file which relates to the heated bed but I can't find any instructions on which bit(s) to change.

pert

Please post a link the download you are currently using and I'll look into it.

Is the board type the only thing you've changed?

I agree that the instructions are pretty confusing.

ScrambledEggs

This is the Marlin download I'm using https://github.com/MarlinFirmware/Marlin


I've swapped out the Configuration.h and Configuration_adv.h files for the kossel_mini version in the zip file.

following the instructions here: https://github.com/MarlinFirmware/Marlin/wiki/Marlin-Configuration

I enabled SD card support and enabled the REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER.

That's all I've done.


Thanks for your help!

pert

This is the Marlin download I'm using https://github.com/MarlinFirmware/Marlin
That's not a download, that's a repository that contains many different downloads. I need the exact download link you used to make sure I'm not wasting my time looking at a different version from what you have.

ScrambledEggs

Apologies - I'm not sure how link to the download. From that page I just clicked on the green 'clone or download' button towards the top right of the page, then 'Download ZIP'.

pert

Change Configuration.h line 232 from:
Code: [Select]
#define TEMP_SENSOR_BED 11
to:
Code: [Select]
#define TEMP_SENSOR_BED 0
That configures Marlin for there being no temperature sensor in the bed and it now compiles for me. Note that I don't have any experience with 3D printers and only a minimal familiarity with Marlin and I haven't looked at any other parts of your configuration so you definitely want to be sure everything is set correctly for your hardware.

ScrambledEggs

Thank you very much!

It would have taken me hours to get it working!

It's uploaded and looking good so far. I've not tested anything yet though.

Go Up