Go Down

Topic: Bootloader write failure - avrdude efuse problem (Read 22884 times) previous topic - next topic

Mr._Swarf

As stated earlier in this thread this is more of a warning than an error. You can ignore the warning and get on with your final.
M.S.

rezaei

but how can I ignore that warning. I did all as explained in this threat. but the warning is still there.
would you please help me.

I checked the board.txt  (the main board.txt, there is only one file) and I checked the value of efuse all is correct.

i do not know how to get ride of this warning.


pert

but how can I ignore that warning.
Just pretend you didn't see it. Close your eyes if you must. This doesn't indicate any problem at all.

ReverseSun

#18
Mar 29, 2017, 08:48 pm Last Edit: Mar 29, 2017, 09:35 pm by ReverseSun
Guys Found the way. Just like our friend *CrossRoad said it just not for nano you can search and find uno, Yun and ... in boards.txt then you can edit the board's .bootloader.extended_fuses=0x05 to .bootloader.extended_fuses=0xfd and done! It won't have any warning!

pert

...or you can just update to the latest version of the Arduino IDE or Arduino AVR Boards, where the fuse values have already been changed:
https://github.com/arduino/Arduino/commit/a899b9e1a8d6522d161c2d81fdbcca86ede83294

MeSat

Just to let people know, I couldn't burn the bootloader using the latest boards files from Arduino.  I downgraded from 1.6.17 to 1.6.10 and changed the boards.txt file in

   ~/.arduino15/packages/arduino/hardware/avr/1.6.10/

to the recommended settings.

I had spent 2 hours searching and editing files on my system.  For peoples information, I found at least 6 different boards.txt files on my system.  Only two of them seemed to have any affect on the IDE.  If the one listed above or the /etc/arduino/ boards.txt files were missing, then the IDE wouldn't start.

Programmed 4 CPU's once I got things working.

It may be worth downgrading to an earlier version if you are having issues.



pert

Latest version of Arduino AVR boards is 1.6.18 but it hasn't been released to Boards Manager so it's only available by installing Arduino IDE 1.8.2.

As for your issue, I'd need to have more information to say what the actual problem was. There shouldn't ever be any need to edit boards.txt. If you do need a modified board then you should create your own hardware package.

MeSat

I saw 1.6.18 but didn't try it.  Needed to get some bootloaders installed for tomorrow.

Editing the boards.txt file is due to an error with the returned fuse info from a new, never a bootloader ATMEGA328P-PU processor.  Trying to burn this processor without the change to the boards.txt gives an error.  From what I learned last night, it is related to a change in avrdude and the IDE is sort of caught in the middle.

I not that experienced to know all the details.

Just checked the boards.txt and all the extended fuses are set to 0xFD for the atmega328 instead of the default 0x05.  No problems with burning the bootloader.

Does that help you understand?


just4ho


pert

Use Arduino version 1.0.3
It was only ever a helpful warning that you could safely ignore. The warning has been removed in the latest release of the Arduino IDE because it kept freaking people out who don't understand the difference between a warning and an error. Why would you advise people to use an IDE version that has been obsolete for 4 years?

poppy381

I spent a lot of time on it.

Changing Board.txt located on ProgramFiles doens't change anything...

Then I've inspected and find another board.txt located on :

C:\Users\Franck\AppData\Local\Arduino15\packages\arduino\hardware\avr\1.6.20

I change this file content, then restarted Arduino IDE program, then burn the bootloader and it works.

Maybe it could help someone.

pert

I spent a lot of time on it.
Why? I already said that you can safely ignore the warning.

turbozob

I had write success on Pro Mini 8MHz but extended fuse was the same. I tried poppy381 solution post #25
 and it worked. Different boards.txt file in different location.
The man who asks a question is a fool for a minute, the man who does not ask is a fool for life. -Confucius

Go Up