Go Down

Topic: Mac Crashes when pulling-in any arduino baord after upgrade to Sierra (Read 3900 times) previous topic - next topic

avnerg

after working heavily with Arduino IDE with previous versions of MacOS,

My MacPro crashes when i plug in the arduino board USB cables, regardless if Arduino IDE is open or not.
During boot it will crash again until i plug off the Arduino cable.

tried to upgrade to the recent Arduino IDE, tried different USB cables, different Arduino boards. same results.

any ideas ?


Crash logs attached.

rpt007

This is reported when using an Arduino clone with CH340 chips on board and "old" drivers.
Here:
https://github.com/adrianmihalko/ch340g-ch34g-ch34x-mac-os-x-driver
it is explained how to remove the old river and a place to download a "Sierra compatible" driver.

I can't tell if that really works, but I read some comments of successful repairs. One guy said, he used a "better" USB cable, which solved the problem. Ok - I am still on Yosemite and wait to jump to Sierra only, when I find less reports on Sierra / Arduino crashes as I a have a mix of originals and clones.
Before you ask:
Did you really read and understand How to use this forum ?
AND:
Do you have already some solution or is a part of the problem sitting in front of the screen?  :)

AntInvent

This should help:

https://www.simplicate.info/2016/09/16/ch340-drama-osx-10-12-sierra-16a313a/

rpt007

@AntInvent:

Original poster hasn't come back for a while -. so he might have either found a solution or given up.
Your link is ok, but it should be used in conjunction with the link to Yu Wang's reply (new driver installation).
Before you ask:
Did you really read and understand How to use this forum ?
AND:
Do you have already some solution or is a part of the problem sitting in front of the screen?  :)

hmfifty

The link provided by rpt007 solved my problem.

Thanks for the help folks!   :)


Go Up