Go Down

Topic: IDE will not start up -- Java problem (Read 3825 times) previous topic - next topic

DjNatan

I've been working on this for hours, have read several forums without a solution.

I installed the latest version of Java and the IDE. The IDE splash screen appears for a brief time and then disappears. The IDE fails to start without reporting errors.

I've uninstalled virus protection, tried to use a different JRE, reinstalled the software -- nothing works.


I am about to start teaching a new unit using little bits, we've invested a lot of money in the equipment and now it seems that we cannot run the IDE.

Anybody have any ideas?   

pert

Please run arduino_debug from the command line and post the output here using code tags(</> button on the toolbar).

DjNatan

That was quite helpful. Thank you.
I found that the properties of the Arduino IDE preferences file needed to be changed to allow all users full control. An unusual error.
After changing the properties of the file, the IDE launched.


----------OUTPUT --------------

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Program Files (x86)\Arduino>arduino_debug.exe
Loading configuration...
Initializing packages...
Preparing boards...
java.io.FileNotFoundException: C:\Users\Image\AppData\Local\Arduino15\preferences.txt (Access is denied)
        at java.io.FileOutputStream.open0(Native Method)
        at java.io.FileOutputStream.open(FileOutputStream.java:270)
        at java.io.FileOutputStream.<init>(FileOutputStream.java:213)
        at java.io.FileOutputStream.<init>(FileOutputStream.java:162)
        at processing.app.legacy.PApplet.createWriter(PApplet.java:559)
        at processing.app.PreferencesData.save(PreferencesData.java:118)
        at processing.app.Base.<init>(Base.java:340)
        at processing.app.Base.guardedMain(Base.java:219)
        at processing.app.Base.main(Base.java:132)
java.lang.RuntimeException: Couldn't create a writer for C:\Users\Image\AppData\
Local\Arduino15\preferences.txt
        at processing.app.legacy.PApplet.createWriter(PApplet.java:571)
        at processing.app.PreferencesData.save(PreferencesData.java:118)
        at processing.app.Base.<init>(Base.java:340)
        at processing.app.Base.guardedMain(Base.java:219)
        at processing.app.Base.main(Base.java:132)

C:\Program Files (x86)\Arduino>

Duivleo

Hello,

I had a similar problem and spent days on resolving this. And eventually I did resolve it.

I believe that the culprit is the Folder:  c:\users\XXXXX\AppData\Local\Arduino15
Whereby XXXXX is your user-name in Windows.

I "just" deleted the folder and everything was right. OK, you will have to set your preferences again and exit Arduino in a normal way to store these. (You may have to unplug and plug-in your Arduino again in order to see the correct com-poort.)

I think that deleting that folder will do the job; but if you are not sure:

Here is what I suggest you do:

a) First of all: try to save all your data by renaming/copying the following directories
         c:\users\XXXXX\AppData\Local\Arduino15  <This path might be HIDDEN, so adjust your Explorer-view.>
         c:\users\XXXXX\Documents\Arduino    <assuming you were storing your sketches here>
                     <This might not be necessary, but better safe then sorry; you can always rename it back.>

         c:\progam files\arduino

(Renaming is almost the same as deleting, but you still have a copy.)

b) De-install Arduino and Java

c) Install latest version of Java (first) and Arduino.
  (Restart Comp in meantime and have CCleaner clean up registry in between during steps b and c.)

d) Start Arduino IDE and set your preferences; Then Exit Arduino to make changes effective.)

I hope this helps.

Good luck,
Leo






 





         

Duivleo

PS:

I don't think it is a Java problem. I am more and more convinced that C:\users\XXX\AppData\Local\Arduino15 is the blame of all the problem.

I got desperate and thought F... this and deleted the whole folder and everything was OK.

Why it occurs? I have no idea.

The only thing I know is that when you remove Arduino IDE and install new version, this particular  folder is not removed or changed.

So, probably resulting in New Language in Old Environment?

Deleting the folder completely worked for me. (Mind you I was desperate at that time; it didn't work anyway, so I had nothing to loose.)

Regards,
Leo

johnwasser

A bunch of people have had IDE 1.6.x problems, including IDE crashes and bizarre compile errors, when they had a previous 1.5.x/1.6.x installation.  At least some of those problems seem to be caused by incompatible executables and preference files that the IDE saves outside the IDE installation directory.  Perhaps that is what is causing your particular problem.  In such cases it appears that the fix is to delete or rename the old "Arduino15" directory and re-install 1.6.x.

On Mac OS X:
/Users/(username)/Library/Arduino15   (a.k.a. ~/Library/Arduino15)
(Note: The 'Library' folder is greyed out in Finder. The folder can't be opened with a double-click. To browse the contents of 'Library', ctrl-click on it and select "Open in New Tab" from the pop-up menu.)

On Windows delete or rename both:
Arduino IDE 1.6.5r5 and previous: C:\Users\(username)\AppData\Roaming\Arduino15
Arduino IDE 1.6.6 and later:      C:\Users\(username)\AppData\Local\Arduino15

On Linux:
/home/(username)/.arduino15    (a.k.a. ~/.arduino15)
(Note: file/folder names starting with '.' are not normally shown in directory listings.  Use 'ls -a' to get a directory listing that includes the hidden files.)
Send Bitcoin tips to: 1G2qoGwMRXx8az71DVP1E81jShxtbSh5Hp
See who has no social life: https://forum.arduino.cc/index.php?action=stats :)

GaryiLyons

Like Leo I also spent hours trying all forms of 'solutions' from blogs.
None worked, and most misunderstood the exact issue.

Leo's solution of deleting
c:\users\XXXXX\AppData\Local\Arduino15

worked a treat.  IDE now restored.


Issue had been that IDE would apear to start, put up opening splash screen, then simply crash/disappear.
No error messages, no indication of what happened whatsoever.

All attempts at uninstalling and reinstalling, even various previous versions, simply failed.

Cheers
Gary

dougt49

I had the exact same problem and it was fixed by doing as you suggested: delete c:\users\XXXXX\AppData\Local\Arduino15

Thank you VERY much.

Go Up