Go Down

Topic: Arduino suddenly not working? (Read 593 times) previous topic - next topic

cenright41

I'm just a beginner and but the elegoo super starter kit. for the past 4 days or so ive been having a ball doing all the projects that come with said kit, steadily chipping away at each course. last night I did lesson 11 or 12 that dealt with relays and it has you hook up a motor to a relay so you can get an idea of how it works. long story short I did the project, it was very cool and worked as advertised.

        today I jump on the computer and start the next lesson but, when I go to load the new code onto my Arduino it gives me an error message

                        Serial port 'COM3' not found. Did you select the right one from the Tools > Serial Port menu?

         when I go to check the "Tools" menu the Serial Port section is grey and not able to be accessed. I have not changed anything from the last time I used it to attempting to use it now. why can I not load any new code? the Arduino does light up and the "on" light is light.

ballscrewbob

Grrr another elegoo...

Few questions if you dont mind.

OS ?
IDE version ?
Do you see the Arduino listed in your hardware configurations anywhere ?
Have you tried another USB cable ?

WARNING.
Please dont USB 3.0 with Arduinos as they results are a little unpredictable.

Also anything else you can add at all. You might be surprised at what could help.
It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

manor_royal

#2
Feb 08, 2017, 04:36 am Last Edit: Feb 08, 2017, 04:42 am by manor_royal
I have no idea what an "elegoo" is, presumably a brand?- but whenever I have any errors like that it's never been a permanent thing and so far if I'm certain the settings are correct, a total power off/ power on has done the trick. (It has happened that I had just fired up, like OP presumably did on a new day, but a re-start somehow aligns the planets.)


edit: went to elegoos' site. Not sure I'd trust a vendor that uses fake Latin Lorem ipsum style text on their face to the public ;)

If this was a Civil Engineering forum would there be posts like "I need to build a bridge. Someone send me drawings."

Go Up