Go Down

Topic: Problema con el puerto serial usb en MAC OS X (Read 18160 times) previous topic - next topic

petaykubata

Tengo un Arduino Uno y en mi ordenador con MACOS X solo me detecta 4 puertos seriales:

 /dev/tty.Bluetooth-Incoming-Port
 /dev/cu.Bluetooth-Incoming-Port
 /dev/tty.Bluetooth-Modem
 /dev/cu.Bluetooth-Modem

He probado instalando drivers ftdi pero no he conseguido nada.
Alguien me puede ayudar?

perrociego

Hola:

Que raro.
¿Ejecutaste el entorno de programación de Arduino?. ¿es el ultimo?
¿que Arduino tenes? ¿se prenden alguna luz en el Arduino?
En la computadora de mi casa se conecta a travez de un puerto que se llama "/dev/cu.usbmodem621".
Y me acuerdo de haber hecho nada especial para instalarlo en ninguna mac.

Saludos


ahernandovalbuena

Es un error típico de placas de arduino no originales ¿Tienes una revisión de Arduino UNO oficial? ¿Has instalado todos los drivers necesarios?

Adjunto algunos post relacionados:

( En este post yo soluciné el error que comentas ejecutando cómo administrador el IDE de arduino desde la carpeta de Descargas )
http://forum.arduino.cc/index.php?topic=165423.0

( En caso de que el error que te aparezca es que esté en uso)
http://forum.arduino.cc/index.php?topic=139464.0

Un saludo.
Alvaro Hernando Valbuena

Kuwito

Haz lo siguiente en orden:

-Desconecta arduino y sal del ide.
-Conecta arduino, espera 5 segundos y ejecuta el ide.

Ya debería de encontrarte el com.

(A mi me ha pasado y creo que es por el refresco de los com en el ide, y como no es posible refrescarlo a mano, pues toca salir y entrar)

Ojo, hablo de Mac, en Windows se comportará de otra manera.

Un saludo.

petaykubata

Todavia no he conseguido solucionar nada, las luces de arduino si que se encienden pero me siguen saliendo solo los cuatro puertos seriales por bluetooth, ninguno por usb...

Kuwito

Ejecuta en Terminal este comando con el arduino conectado:

Code: [Select]
system_profiler SPUSBDataType

Si no te aparece en la lista es que no lo ha reconocido el sistema.

Prueba a reiniciar el ordenador y encenderlo con el arduino conectado para forzarlo y en caso de no funcionar puedes intentar resetear la pram y la nvram (ojo, en última instancia).-

PRAM
NVRAM

Un saludo

Sergifez

Buenas, soy nuevo en el foro, tengo uno Arduino uno original que funciona perfectamente el OSx Sierra, pero otro chino recién llegado con un kit, no era capaz de reconocerlo. Por lo que no era problema ni del IDE, ni del cable, ni de los driver FTDI.

LA SOLUCION:

El problema en mi caso, fue que el arduino uno compatible, no lleva el chip atmel para el control de los puertos, sino uno de bajo coste que se llama ch340 (serie ch34x). Instalando los driver para ese chip desde aquí: https://blog.sengotta.net/signed-mac-os-driver-for-winchiphead-ch340-serial-bridge/

se soluciono el problema.

Go Up