Go Down

Topic: problem with usb to serial cable on 340 chip (Read 358 times) previous topic - next topic


Hi Everybody,
Excuse me for similar question about this problem.
Recently I bought a USB to serial cable to work with my win10. I bought in
On eBay (American seller from Texas, http://www.ebay.com/itm/370862895479?_trksid=p2060353.m2749.l2649&ssPageName=STRK%3AMEBIDX%3AIT). I downloaded the driver
CH341SER.zip, installed it. Everything seemed OK as computer recognized the dongle and assigned a port.
Unfortunately my luck ended here as I could not upload any sketch. It gave me usual " not in sync: resp=0x00" answer.  I searched and read almost all posts about this problem.  Some suggested that the Arduino may not have the bootloader so I checked my Arduino pro mini on my old XP computer with an old Prolific cable and it worked OK. Then I checked the new cable with loopback test using Arduino's Serial Monitor. At first connection it worked and returned whatever I typed. After this I connected my pro mini and tried to upload something. Result was the same '"no sinc ....". After this I tested the loopback and it did not work as well. In order to make the loopback test to work I had to unplug and plug the cable and restart the Arduino. I even tried to switch RX and TX although the cable has a DB9 end and its pins are defined.  So I am puzzled what is going on with this cable. I know that this is a not easy problem. Any help will be very much appreciated.
Thanks,      Simon


When you start a download, the IDE will show "compiled xxx of 32xxx bytes", press Reset on the Promini when you see that, as it sounds like your adapter does not have the DTR signal brought out to the Reset pin on the Promini.
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.


Thank you Crossroads for quick answer. Actually it has the DTR signal and I can see that the led on pin 13
blinks 2-3 times. But I also tried to disconnect the DTR pin and do reset manually as you suggest.

Go Up