Go Down

Topic: No programmer specified? (Read 633 times) previous topic - next topic

Johnredearth

Hi

Been using arduino off and on for a couple of years.  Lately I have had this annoying update popup which I don't seem to be able to get rid of.  Its a very clunky interface that I don't understand.

Anyway I persevered today to get rid of it and something was updated. 
Now when I try to use arduino it won't load saying

avrdude: no programmer has been specified on the command line or the config file
         Specify a programmer using the -c option and try again

Also, I have a menu option called 'Programmer, Arduino Gemma.'  I have no idea what is happening here.  Can anyone help I have work to do!

John

pert

Lately I have had this annoying update popup which I don't seem to be able to get rid of.  Its a very clunky interface that I don't understand.
Yeah, that thing is terrible. Please, if there's a Java master out there reading this, help the Arduino developers improve it. They and all of us would be very grateful.

something was updated.  
Now when I try to use arduino it won't load saying

avrdude: no programmer has been specified on the command line or the config file
         Specify a programmer using the -c option and try again
The problem can be caused by using Arduino IDE 1.6.8 or previous with Arduino AVR Boards 1.6.12 or 1.6.14. They are incompatible. You can fix it by either:
  • Updating to a version of the Arduino IDE newer than 1.6.8.
  • Install a version of Arduino AVR Boards other than 1.6.12 or 1.6.14 via Boards Manager.


I have fixed the issue causing the backwards incompatibility so this issue will not occur with Arduino AVR Boards 1.6.15 and upwards.

Also, I have a menu option called 'Programmer, Arduino Gemma.'  I have no idea what is happening here.  
If you don't own a Gemma then just ignore it.

Johnredearth

HI

I re-downloaded and all is fine.  I agree, that upgrade software is pretty bad!  Thanks for the pointers

Go Up