Go Down

Topic: IDE 1.8.0 Released -- update: 1.8.10 (Read 168355 times) previous topic - next topic


I run Arduino IDE from the Raspberry Pi B; it is version 1.0.1.

I have run the update and upgrades from sudo but the version remains the same.

I downloaded the Arduino 1.8.7 Linux Arm zip file.

Two questions: Is the Linux Arm the right version when running from the Pi?
                       Are there any step by step instruction for update IDE with the zip file?

Believe me I looked for a long time and couldn't find any information.




I have run the update and upgrades from sudo but the version remains the same.
The Arduino IDE version in the package manager is extremely outdated due to insufficient licensing documentation in the more modern versions of the Arduino IDE:
I thought it was Arduino IDE 1.0.5, but regardless, you should never install the Arduino IDE from a package manager (e.g. `apt-get`). Always download the official version from http://www.arduino.cc/en/Main/Software.

Is the Linux Arm the right version when running from the Pi?

Are there any step by step instruction for update IDE with the zip file?
How about the ones I already gave you earlier today?:
  • Download the latest "Linux ARM" version of the Arduino IDE from https://www.arduino.cc/en/Main/Software
  • Right click on the downloaded file and select "Extract Here". The folder arduino-1.8.7 will be extracted from the downloaded file.
  • You can move this folder to any convenient location on your drive.
  • To start the Arduino IDE, run the file arduino-1.8.7/arduino.

There is also an install script but it's not necessary to run that. It just creates a shortcut on your desktop.
Believe me I looked for a long time and couldn't find any information.
If you're going to ask for help here on the forum, the least you could do is read the responses from the people trying to help you. I probably spent at least 5 minutes writing that reply because I actually booted up my RPi to make sure I got it right. There are plenty of other things I could spend my Saturday doing.


Geez don't be so harsh.  I did come back but couldn't find any replies; my fault because of noobi to the forum.  However I do appreciate the reply.


Well Pert,

Thanks for the support, I appreciate it and have successfully installed the latest revision.  When trying to upload a sketch it is asking me for a port but I think I can figure that out.

Again, I am a noob and apologize for not seeing your first reply.




OK Pert,

Of course the port problem was resolved easily and my sketch compiles successfully.  However during the upload I get an error:

 /home/pi/Desktop/arduino-1.8.7/hardware/tools/avr/bin/avrdude: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.17' not found (required by /home/pi/Desktop/arduino-1.8.7/hardware/tools/avr/bin/avrdude)
An error occurred while uploading the sketch

I went through the sudo apt-get update and sud apt-get upgrade but the error still persists.  Any suggestions?

Thanks again,

Just Roger


Well I decided to update from Wheezy to Jessie because of the GLIBC error I was getting during uploading after installing Arduino IDE version 1.8.7.  Did a lot of online research and decided that this would solve the problem.  There may be an easier way but I couldn't find it.

Just finished and everything and I am now able to use Arduino IDE 1.8.7 to successfully compile and upload. 

Again thanks for the help Pert.

If anyone is interested here is how I made the transition:

1. Backed up my sketches to a stick.
2. I made sure Wheezy was up to date by running the following commands:

   %sudo apt-get update
   %sudo apt-get upgrade
   %sudo apt-get dist-upgrade

3. Substituted Jessie for wheezy in files: source.list, collabora.list, and raspi.list with the following commands
   %sed -i 's/wheezy/jessie/g' /etc/apt/sources.list
   %sed -i 's/wheezy/jessie/g' /etc/apt/sources.list.d/collabora.list
   %sed -i 's/wheezy/jessie/g' /etc/apt/sources.list.d/raspi.list

4. Rebooted the Arduino
    %sudo reboot

5. Now updated Jessie

   %sudo apt-get update
   %sudo apt-get upgrade
   %sudo apt-get dist-upgrade

6. Confirmed that the Raspbian version is now Jessie:


It now lists Jessie.  I was able to successfully compile and upload sketches using Arduino IDE version 1.8.7

Now I am a noob at this and appreciate the support of Pert and the online documentation provided by LINUXCONFIG.org and raspberrypi.stackexchange.com.  I basically combined all the information received into the procedure above.

Again I have only been using the system for a short time after these changes and it appears to be working fine but only time will tell.

Additionally, when prompted during the long process I just selected the default options (hitting return) assuming they were default for a reason.  Some of the other options may be better but I just stuck with the default.


I'm glad to hear it's working now. I had turned on my RPi to look into this but you solved it before I had gotten around to it. It wouldn't have helped anyway since I'm using Raspbian Stretch.



hello friends
iam form Egypt and i just have received Arduino and LCD with a lot of pins
idon't know how to start
any help ??


First of all: Welcome to this forum.

What LCD, what Arduino ????

Before we can give you precise assistance, pls start with reading the guidelines of this forum and come back with your question(s) in a way that we don't have to ask our crystal balls what you might have in mind.  :smiley-confuse:
Before you ask:
Did you really read and understand How to use this forum ?
Do you have already some solution or is a part of the problem sitting in front of the screen?  :)


Hi All!  +Karma to the developers who keep making Arduino bigger and better.

I need some advice.

I just tried to update to v1.8.7 to replace a good installation of v1.8.5 that I have used since Jan/2018.  No joy!

The v1.8.7 installer reported success but the IDE would not run past the splash screen and ended without displaying any error messages. I uninstalled and reinstalled several times, downloaded and installed a fresh copy, ditto, restarted after a fresh installation, ditto, downloaded and installed v1.8.6, ditto, and finally reinstalled v1.8.5 to get Arduino IDE running just fine again.

Can anyone help me troubleshoot the v1.8.7 installation?  Here are some of my system particulars:
   * Windows VISTA Home Premium, 64-bit, SP2
          Intel Core Duo CPU, E7000 @2.66GHz, 4GB RAM
   * Arduino IDE installed at \Program Files (x86)\Arduino\
   * Arduino sketches and libraries installed at \Documents\Arduino\
   * Java on system is (older) Java 7 Update 5 (,
         but I see that Arduino v1.8.5 packs its own (later) version of Java

Thanks for your time to consider and answer.



the IDE would not run past the splash screen and ended without displaying any error messages.
Please run the file arduino_debug.exe from the command line. You'll find it in the Arduino IDE installation folder. After the IDE fails to load you should see some output in the command line window. Copy that output and paste it here, using code tags (</> button on the toolbar).


Hi pert!

OK. I did as you suggested. This time Arduino v1.8.7 *did* run AOK!  I suspect the difference may have been that I manually deleted the working installation of v1.8.5 through the Control Panel | Programs and Features, while previously I had allowed the Arduino Windows installer to do the removal of the old version.  I will go through the whole process again, both ways, to test this hypothesis.  But it is late now so it will have to be tomorrow PM.

I did run Arduino_debug.exe and saw the command window debug output.  It shows no sign of errors at this point:
Code: [Select]

Microsoft Windows [Version 6.0.6002]
Copyright (c) 2006 Microsoft Corporation.  All rights reserved.

C:\Program Files (x86)\Arduino>arduino_debug.exe
Loading configuration...
Initializing packages...
Preparing boards...

Thanks for you input so far. I would like to find out why I had such trouble on the first round of installations and I will followup and provide any additional information I can.



Hi pert!

I deviated from the approach I originally conceived but in the end I did not have any problems upgrading from a good installation of Arduino v1.8.5 to v1.8.7 using the Windows installer provided.  I suspect that my troubles were due to some messy housekeeping after many upgrades from the early days of Arduino. Mea culpa!  The only tip I can offer is that if anyone is having a problem similar to mine, then clean out Arduino and start fresh.

Thank you again for your attention and suggestion to help me debug this problem.

For the record, here is a summary of the steps I took and results:
   1. Uninstalled all traces of Arduino (within reason, not the USB and DFU drivers):
       a. Removed Arduino v1.8.5 using Control Panel | Programs and Features
           (This removes \Program Files (x86)\Arduino\ files)      
       b. Deleted \Documents\Arduino\ folder
       c. Deleted \AppData\Local\Arduino15\ folder  (hidden under User)
       d. cleaned out a few remaining registry entries with "Arduino" in them
       e. Restarted the system

   2. Completed a new installation of Arduino v1.8.5, which had previously worked for me
       a. whole installation went AOK and the IDE ran fine
       b. installed SAM boards v1.6.11, megaAVR boards v1.6.3 and updated AVR boards to v1.6.3
       c. compiled sketch BlinkWithoutDelay for Due AOK
       d. copied Arduino_STM32 to \Documents\Arduino\hardware\ folders and
           installed STM32 Windows drivers (Maple_serial)
       e. closed Arduino IDE and restarted it

   3. Changed board to Generic STM32F103C series
       a. opened the STM32 Blink example sketch, edited it for the Blue Pill LED pin
       b. compiled and uploaded the sketch AOK and sketch ran AOK

   4. Completed a new installation of Arduino v1.8.7
       a. used/allowed Arduino v1.8.7 Windows installer to remove the previous v1.8.5 installation AOK
       b. compiled, uploaded and ran the same sketch AOK
       c. edited a slightly different sketch (fast Blink), compiled, uploaded and ran it AOK
That was enough for me!  I have landed where I wanted to be originally.  The cause of my troubles is still somewhat mysterious but they can be overcome.  This may have been a tempest in a teapot but I really appreciate that this forum is here to ask and receive help.



I'm glad to hear it's working for you now. Thanks for sharing your findings. I'm sure anyone else having this problem will be very grateful. Enjoy!

Go Up