Go Down

Topic: IDE 1.8.0 Released -- update: 1.8.10 (Read 149920 times) previous topic - next topic

pert

Rolling back to 1.8.9 after trying 1.8.10 because:

Serial Plotter operation too different and seemingly without documentation on said differences.  Plotter in previous versions used to ignore all text except digit strings separated by whitespace.  All my sketches took advantage of that to output troubleshooting text along with plot points.  The plot point colors in 1.8.10 Plotter aren't coherent with the colors of previous versions of IDE Plotter in a way or ways I'm not discerning.  If the Plotter is going to change that drastically, I'd like some documentation, please.

OS: Linux Mint 18.1

Just wanting devs  to know....
The only change I'm aware of between Arduino IDE 1.8.9 and 1.8.10 is the addition of a feature to allow labels:
https://github.com/arduino/Arduino/pull/7453
There is documentation of this here:
https://github.com/arduino/Arduino/blob/master/build/shared/ArduinoSerialPlotterProtocol.md
That documentation is exceptionally well hidden and I do think the Serial Plotter in general should be fully documented in a logical place here on the website with the rest of the Arduino user documentation. There was some discussion about that in the pull request thread, but unfortunately it didn't go anywhere yet.

ballscrewbob

#376
Nov 29, 2019, 07:26 pm Last Edit: Nov 29, 2019, 07:26 pm by ballscrewbob
@LisaAlix

  • Always provide as much detail as possible to your issue it may be important.
  • If applicable provide your SKETCH inside CODE TAGS ( </> ) or a CREATE share link.
  • If applicable provide a schematic even if hand drawn.
  • How to insert a picture into your post
  • If applicable provide a proper LINK to the hardware / sensors etc. you are using.
Bob.

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

zebios

I personally had no problems with the app version but i will switch to fully installed program.

gauravwarade

botrio arduino 2.1 having issue while uploading any code via arduino IDE 1.8.0 also i have checked board selection and arduino as ISP selection and port selection was ok.
For this board any other circuit or software library file
please suggest
 

Go Up