Go Down

Topic: Domogarden: Gestion de piscine et arrosage intégré (Read 79186 times) previous topic - next topic

tartiflette

bonjour,
Non, tu ne peux pas simplement supprimer les pages. Des appels a des fonctions y font référence.
Il faut également modifier le code.

proft

Bonjour,

Ok merci de ton retour, je vais essayer alors!

skyzo-boy

Bonjour à tous et surtout poo pool,

En lisant tes conseils j'ai changer mon interface de mesure mais j'ai mon problème de mesure de chlore,  je suis entrain de de faire un montage pour couper mon électrolyseur à base d'Arduino.

Matériel :
- Arduino
- sonde chlore https://www.piscinemateriel.fr/traitement-automatique/212-so[...]de-d-analyse-redox.html
- Adaptateur pH/ORP 1130 https://www.gotronic.fr/art-adaptateur-ph-orp-1130-12112.htm
- Gravity: Digital I2C Signal Isolator https://www.dfrobot.com/product-1621.html

Lorsque je met mon montage dans une solution de calibrage de sonde 650 mV, 460mV et 220mV, tout fonctionne correctement à 5mV près.

Mon taux de chlore dans la piscine est de 0,5 et lorsque je trempe ma sonde directement dans la piscine j'ai 80mV.
Si je la met dans le porte sonde après la pompe et la filtration, j'ai 230mV.

Donc mes valeurs sont trop basse.

Qui à trouver la solution à ce problème?

Si de met une chambre de mesure cela changera-t-il qqch?

Merci de vos réponses.

TheLapin

Hypothèse

Lorsque tu mets ta sonde dans la solution de calibrage et que la valeur est correcte, c'est le même arduino qui est utilisé, dans le local piscine, avec la pompe en marche ?
Si oui => si tu prélève de l'eau de la piscine dans un flacon, que donne la mesure ?
Si la mesure est "correcte", je pense que tu as un soucis de perturbation "électrique" (pas de poolterre ?)

Si la mesure n'est pas correcte, ne m'invite pas a me baigner car c'est que ton eau n'est pas bonne !

Quand tu dis que ton taux de chlore est a 0,5, tu parle bien du taux de chlore libre a 0,5 mg/litre, mesurée avec des bandelettes AquaCheck ?

Attention : Certains testeur genre testeur a pastille donne une valeur de chlore dite "total" (= chlore libre + chloramine). Si il y a trop de stabilisant et que l'eau est dite "morte", le taux de chlore total peut être à une valeur correcte mais le taux de chlore libre être à 0 : l'eau est donc chargée en chloramine et donc l'eau n'est plus désinfectante =>  le redox va donc être bas)

thebadboy

#454
Aug 21, 2020, 11:26 am Last Edit: Aug 21, 2020, 11:31 am by thebadboy
voila plus d'un moi que je galère avec le redox, j'ai tester plusieurs chose sans succès.

dans mon étalon 468, j'ai bien une valeur de 468. Des que je met la sonde dans la chambre ou même dans une bouteille avec de l'eau de piscine ma valeur monte a 900-1000 alors que j'ai zero de chlore libre. Même lorsque l'eau se dégrade visuellement et début d'algues sur les parois la valeur ne bouge pas d'un yota. Ne trouvant pas le problème je commande un étalon 650 , je teste et ma sonde me sort 645.

j'en déduit que le problème ne vient pas du système mais de l'eau en elle même.

j'ai environ 30 ppm de stabilisant mais j'utilise de l'eau adoucie ( adoucisseur de sel).

Qu'est-ce qui pourrait leurrer la sonde en lui disant que l'eau est oxydante alors qu'elle ne l'est pas vu que l'eau se degrade.


j'ai un tac de 80 et une eau très douce. mon ph est a 7.4

TheLapin

7.4 : un peu haut, l'ideal est a 7.2
Concentration de nitrate trop élevé ? (zone venteuse avec agriculture à proximité - peut faire monter le redox)
Que dit la sonde avec de l'eau de remplissage (donc sans stabilisant et autre ?) et avec de l'eau du robinet ?

je ne sais pas si l'eau adoucie a une influence sur le redox.

thebadboy

#456
Aug 21, 2020, 05:27 pm Last Edit: Aug 21, 2020, 05:30 pm by thebadboy
si je test avec de l'eau du robinet, adoucie ou non j'ai des valeurs avoisinant les 900.

En belgique, il y a du chlore dans l'eau du robinet pour éviter la prolifération mais je ne connais absolument pas la valeur redox en sortie de robinet. tout ce que je sait est qu'ils ne peuvent pas dépasser 1/4 de ppm de chlore.


question : est il possible que ma valeur soit réelle dans le bassin mais que je sois en présence de l'algue moutarde ?

En résumé, est ce que l'algue moutarde agit sur le fait que l'eau soit ou non oxydante

skyzo-boy

Alors j'ai résolu mon problème.
Ct la sonde chinoise qui dit n'importe quoi dans l'eau de la piscine, par contre elle fonctionne super bien dans les solutions de calibrage.
Donc ma solution pour résoudre mon problème, j'ai acheté une sonde à 100€ chez un pisciniste.
Si ça peux servir à qqun.

thebadboy

c'est quoi la référence de ta sonde a 100€

TheLapin

un petit UP
c'est quoi les référence de la sonde a 100 € et de la sonde chinoise qui ne fonctionne pas ?

Go Up