Go Down

Topic: MEGA2560 avec JTAG activf et Atmel-ICE dans AtmelStudio7 (Read 544 times) previous topic - next topic

Simone72

Bonjour à tous,
Après avoir testé le JTAG sur DUE avec Atmel-ICE J'essaie de comprendre comment déboguer avec AS7.
Me baladant sur le web, j'ai découvert que aussi le MEGA2560 , lors de l'activation du correspondant FUSE via le ICSP, peut avoir le JTAG!

Donc je me suis dit que je devais essayer  ;D

La connexion ICSP n'est pas difficile le câble fournit avec la Atmael-Ice est directement compatible.
Une fois activé le JTAGEN le problème était de trouver la bonne combinaison pour le JTAG sur les entrées analogiques...
Heureusement, j'ai trouve ces Allemands ici :smiley-roll-sweat:
Le deuxième câble fourni avec la ICE a les bout déjà câblés et numérotées.

Qui aurais besoin je les remets ici:

Connecteur 1 - Arduino pin A4
Connecteur 2 - Arduino pin GND 
Connecteur 3 - Arduino pin A6
Connecteur 4 - Arduino pin  5V
Connecteur 5 - Arduino pin A5
Connecteur 9 - Arduino pin A7
Emplacement 0 (10) - Arduino pin GND

Aujourd'hui, enfin, j'ai passé la nuit dessous, le JTAG est utilisable!

Mais je dois comprendre comment utiliser au mieux la suite AS7 pour enfin faire OCD débogage :o
J'ai installé aussi le plug-in Arduino IDE pour Atmel Studio 7, mais je me perd un peu ...
2 X Arduino MEGA 2560

Simone72

J'ai compris que chaque fois que je programme le Mega via le JTAG le Bootloader est effacé... donc pour pouvoir réutiliser la IDE Arduino via USB je doive reinstaller le Bootloader avec AS7. :(

J'ai trouvé le fichier stk500boot_v2_mega2560.hex dans C:\Program Files (x86)\Arduino\hardware\arduino\avr\bootloaders\stk500v2 et remis les FUSE avec cette config:

Extended = 0xFD

High = 0xD8

LOW = 0xFF

Si ça pet servir à quelqu'un..  :)
2 X Arduino MEGA 2560

laurentGodin1

Bonjour,

Après avoir un pas mal cherché. Je me suis rendu compte que le cable squid cable fourni avec Atmel-ICE-C
est decallé : pin1 (fil rouge) du connecteur coté port AVR est libelle (0) sur le connecteur independant.
Maintenant tout fonctionne!!

SQUID Cable 0 - Connecteur 1 - Arduino pin A4
SQUID Cable 1 - Connecteur 2 - Arduino pin GND
SQUID Cable 2 - Connecteur 3 - Arduino pin A6
SQUID Cable 3 - Connecteur 4 - Arduino pin  5V
SQUID Cable 4 - Connecteur 5 - Arduino pin A5
SQUID Cable 8 - Connecteur 9 - Arduino pin A7
SQUID Cable 9 - Emplacement 0 (10) - Arduino pin GND

et ca fonctionne avec Arduino Mega2560 Elegoo R3

Go Up