Go Down

Topic: How to reconnect the MKR to WIFi (Read 9347 times) previous topic - next topic

Sneha7

Hello everyone,

Although this topic is older and about MKR1000; I encountered the same problem with MKR1010. It keeps disconnecting after an hour and won't reconnect until I press the reset button on board.

Has anyone found any solution for this problem?

thetha

Okey. It very Buggy! What has worked for me
1) start arduino ide. (it has to be the offline version with connect mrk it should download some stuff
2) make the update of the mrk board
reboot
3) 5ghz is not working make sure you have it disabled. I have connected the pc and the arduino to a android tablet, very short range.
4) turn the baterry on the motorshield then connect over wifi. I had to try it severeal times.
In my oppinion its very unstable.

Good Luck

ballscrewbob

@thetha

The MKR1000 never had 5 Ghz. 2.4 is the limit.
Most routers now have all the way up to 5 Ghz with secondary settings for both 2.4 and 5.
Simple connect it to the named 2.4.

Mine is still running on THINGSPEAK after over a year but only with updated firmware.
Twice a year I bring it in and check the firmware and update if needed.
Also give me chance to tweak any settings at the same time.


Bob.

It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

ela55

Having compared (2) MKR1000's debug data for more than a month now.
   both experienced disconnects without an automatic ( firmware) reconnect
                  both were updated to  19.5.2 firmware early on

Tried all the application based fixes talked about here with no luck.   One ran recently for 31days before it failed to reconnect - the other would only go 5 -8 days between.

I read the 1.8.9 Arduino update  notes today and saw that it was modified (back in 3/2019) to allow the user to upgrade the firmware to 19.6.1.   Wish I would have checked that earlier.

Upgraded on both units and now hoping that will improve things? 

 Anyone running 19.6.1 firmware and still having issues?

Go Up