Go Down

Topic: Pas de signal avec un générateur d'onde 9833 (Read 866 times) previous topic - next topic

ChPr

Bonsoir à toutes et à tous,

Je viens de recevoir un générateur d'onde 9833 acheté en Chine. Je l'essaie avec le sketch donné par Riva dans sa réponse N° 15 qui semble donner satisfaction à tout le monde ... sauf moi  :'(

Je l'ai essayé avec un Mega 2560, un Uno, un Nano et un Pro mini : pareil pour tout le monde : aucun signal en sortie.

Avant que de râler chez le fournisseur, peut-être que certains d'entre vous verrons une chose que j'ai ratée.

Merci pour vos renseignements.

Pierre
Pourquoi faire simple alors qu'il est si facile de faire compliqué !

J-M-L

Hello - Please do not PM me for help,  others will benefit as well if you post your question publicly on the forums.
Bonjour Pas de messages privés SVP, postez dans le forum directement pour que ça profite à tous

ChPr

Après ce que j'ai raconté dans un autre post, je serais mal venu de vous embêter à cause de mauvaises soudures.

Comme je l'ai dit, j'ai fait le test avec plusieurs types d'Arduino. De plus, j'ai décortiqué le sketch proposé en le confrontant à la datasheet du composant : pas de loup.

Ce que je constate, vu avec un oscillo HP 50 MHz, c'est que la sortie semble "en l'air" ; dès que je touche la sonde, un wagon de 50 Hz apparaît.

Les signaux SPI sont propres et connectés aux bonnes pins.

Tout me laisse penser que le module est HS, mais bon, peut-être qu'il y a quelque chose que je n'ai pas vue.

Cordialement.

Pierre
Pourquoi faire simple alors qu'il est si facile de faire compliqué !

ChPr

Tout est bien soudé?
Ben non !

Le problème, c'est que ce sont pas mes soudures qui sont mauvaises, ce sont celles du module. En promenant la pointe de touche de ma sonde d'oscillo sur les sorties du composant, j'ai pu constater que le signal est bien présent, mais qu'il n'est pas transmis vers la sortie du module. Et là, je ne me vois pas faire une soudure sur ce tout petit composant, mais bon, j'essaierai peut-être quand il fera bien jour.

Cordialement.

Pierre
Pourquoi faire simple alors qu'il est si facile de faire compliqué !

68tjs

Je n'ai pas joué avec l'AD9833 mais avec l'AD9850.
Je n'ai pas été emballé : module instable : les oscillations s'arrêtaient sans raisons visibles et quand l'oscillateur oscillait le niveau de sortie fluctuait avec la fréquence.

Le fait de promener la sonde d'oscillo apporte une petite capacité qui s'ajoute à l'effet de main qui n'est pas modélisable. Il se peut que cela déclenche l'oscillation qui s'arrête dès que tu retire la sonde des endroits fatidiques.
Je pense que ces circuits intégrés sont très délicats et très sensibles à l'environnement extérieur.
Ceux qui savent qu'ils ne savent rien en connaisse autant que ceux qui croient tout savoir et qui n'en connaissent pas plus qu'eux.
Pierre DAC.

ChPr

... Le fait de promener la sonde d'oscillo apporte une petite capacité qui s'ajoute à l'effet de main qui n'est pas modélisable. Il se peut que cela déclenche l'oscillation qui s'arrête dès que tu retire la sonde des endroits fatidiques.
Je pense que ces circuits intégrés sont très délicats et très sensibles à l'environnement extérieur.
Certes, cependant, la broche que je pointe est la sortie du signal, celle qui est connectée directement à la sortie du module. Je ne pense pas que 25 pF soit rédhibitoire pour un circuit de chez Analog Device qui, rappelons-le, n'est quand même pas le perdreau de l'année en ce qui concerne les circuits analogiques.

Le signal que j'observe sur cette broche correspond bien aux valeurs anoncées et de manière stable.

Par ailleurs, une mesure au multimètre confirme l'interruption de conduction entre cette broche et le pad sur lequel elle devrait être soudée.

Je tenterai une soudure, malgré une panne de fer à souder de 1 mm à la pointe qui est un monstre devant le circuit  :o

Cordialement.


Pierre
Pourquoi faire simple alors qu'il est si facile de faire compliqué !

J-M-L

Au fait quand vous dites aucun signal, c'est à l'oscillo? (La sortie attendue du 9833 au mieux  c'est 0,6V - vous voyez vraiment 0V?)
Hello - Please do not PM me for help,  others will benefit as well if you post your question publicly on the forums.
Bonjour Pas de messages privés SVP, postez dans le forum directement pour que ça profite à tous

ChPr

Au fait quand vous dites aucun signal, c'est à l'oscillo? (La sortie attendue du 9833 au mieux  c'est 0,6V - vous voyez vraiment 0V?)
Voir ma réponse #2 Sensibilité max de l'oscillo : 5 mV/div

Le niveau moyen est de 0V alors qu'il devrait être de 300 mV.

Cordialement.

Pierre
Pourquoi faire simple alors qu'il est si facile de faire compliqué !

ChPr

#8
Jan 29, 2017, 11:45 am Last Edit: Jan 29, 2017, 11:53 am by ChPr
Alléluia, victoire, je suis balèze  :) , j'ai réussi à faire ma soudure malgré ma panne monstrueuse et mes yeux tout pourris.

Bien, maintenant, sur la doc, il est dit qu'on pouvait avoir une fréquence jusquà 12.5 Mhz :

0 MHz to 12.5 MHz output frequency range
28-bit resolution : 0.1 Hz at  25 MHz
reference clock Sinusoidal , triangular, and square wave outputs


à un petit (gros) bémol près: Sinus etTriangle jusqu'à 1 MHz, sinon, au-delà, on n'a plus que quelques échantillons par période (normal avec une horloge à 25 MHz).

Le Carré est valide jusqu'à 12.5 MHZ, mais des temps de commutation pas terribles : 40 nS et de plus, ce signal est un signal de 5 V d'amplitude alors que pour les sinus et triangle c'est 600 mV càc.

Cordialement.

Pierre
Pourquoi faire simple alors qu'il est si facile de faire compliqué !

J-M-L

Hello - Please do not PM me for help,  others will benefit as well if you post your question publicly on the forums.
Bonjour Pas de messages privés SVP, postez dans le forum directement pour que ça profite à tous

68tjs

#10
Jan 29, 2017, 03:45 pm Last Edit: Jan 29, 2017, 03:47 pm by 68tjs
à un petit (gros) bémol près: Sinus etTriangle jusqu'à 1 MHz, sinon, au-delà, on n'a plus que quelques échantillons par période (normal avec une horloge à 25 MHz).
Le Carré est valide jusqu'à 12.5 MHZ, mais des temps de commutation pas terribles : 40 nS et de plus, ce signal est un signal de 5 V d'amplitude alors que pour les sinus et triangle c'est 600 mV càc.

Cordialement.

Pierre
Tant mieux pour toi mais je me répète, même si Analog Device est quelqu'un de sérieux, ces circuits ne sont pas faciles à mettre en œuvre : il ne suffit pas de copier un schéma électrique il y a aussi l'implantation sur le circuit imprimé qui compte pour beaucoup. La gestion de la masse entre le numérique et l'analogique est le plus difficile à faire.
Le respect des impédances de charge est très important, souvent ces circuits sortent sous 50 ohms (je n'ai pas vérifié pour celui ci) et pour obtenir les performances annoncées il ne faut pas que le taux de réflexion dépasse 15 à 20 %
Ceux qui savent qu'ils ne savent rien en connaisse autant que ceux qui croient tout savoir et qui n'en connaissent pas plus qu'eux.
Pierre DAC.

Go Up