Go Down

Topic: EasyVR shield for voice recnognition is not working (Read 945 times) previous topic - next topic

nick005

My EASYVR SHIELD doesn't work.. I put it onto arduino mega and programmed with the easyvr commander. And for now is all ok. But then i generated the code and seems that arduino is not receiving easyvr. I'm trying to whink why. I tried all the bridge connections but seems to be not valid.
HELP ME PLEASE
 
Code: [Select]

#include "Arduino.h"
#if !defined(SERIAL_PORT_MONITOR)
  #error "Arduino version not supported. Please update your IDE to the latest version."
#endif

#if defined(__SAMD21G18A__)
  // Shield Jumper on HW (for Zero, use Programming Port)
  #define port SERIAL_PORT_HARDWARE
  #define pcSerial SERIAL_PORT_MONITOR
#elif defined(SERIAL_PORT_USBVIRTUAL)
  // Shield Jumper on HW (for Leonardo and Due, use Native Port)
  #define port SERIAL_PORT_HARDWARE
  #define pcSerial SERIAL_PORT_USBVIRTUAL
#else
  // Shield Jumper on SW (using pins 12/13 or 8/9 as RX/TX)
  #include "SoftwareSerial.h"
  SoftwareSerial port(12, 13);
  #define pcSerial SERIAL_PORT_MONITOR
#endif

#include "EasyVR.h"

EasyVR easyvr(port);

//Groups and Commands
enum Groups
{
  GROUP_1  = 1,
  GROUP_16 = 16,
};

enum Group1
{
  G1_PROVA = 0,
  G1_VERDE = 1,
  G1_ROSSO = 2,
  G1_BLU = 3,
  G1_BIANCO = 4,
  G1_SPEGNITI = 5,
  G1_VIOLA = 6,
  G1_AZZURRO = 7,
  G1_AUTOMATICO = 8,
};

enum Group16
{
  G16_ARDUINO = 0,
  G16_TOMMASO = 1,
  G16_NICCOLO = 2,
};

//Grammars and Words
enum Wordsets
{
  SET_1  = -1,
  SET_2  = -2,
  SET_3  = -3,
};

enum Wordset1
{
  S1_ACTION = 0,
  S1_MOVE = 1,
  S1_TURN = 2,
  S1_RUN = 3,
  S1_LOOK = 4,
  S1_ATTACK = 5,
  S1_STOP = 6,
  S1_HELLO = 7,
};

enum Wordset2
{
  S2_LEFT = 0,
  S2_RIGHT = 1,
  S2_UP = 2,
  S2_DOWN = 3,
  S2_FORWARD = 4,
  S2_BACKWARD = 5,
};

enum Wordset3
{
  S3_ZERO = 0,
  S3_ONE = 1,
  S3_TWO = 2,
  S3_THREE = 3,
  S3_FOUR = 4,
  S3_FIVE = 5,
  S3_SIX = 6,
  S3_SEVEN = 7,
  S3_EIGHT = 8,
  S3_NINE = 9,
  S3_TEN = 10,
};


// use negative group for wordsets
int8_t group, idx;

void setup()


And the serial is on SW
Code: [Select]

⸮Bridge not requested, run normally
---
EasyVR not detected!
EasyVR not detected!
EasyVR not detected!
EasyVR not detected!
EasyVR not detected!
EasyVR not detected!
EasyVR not detected!

Grumpy_Mike

Quote
https://justpaste.it/38533
Please read How to use this forum
Because your post is breaking the rules about posting code.

Go Up