Go Down

Topic: Can't upload sketch to arduino uno (Read 1 time) previous topic - next topic

andrell

Feb 09, 2017, 09:42 pm Last Edit: Feb 12, 2017, 10:32 am by andrell
When i try to upload the sketch (blink) to arduino it says:
Code: [Select]

avrdude: Version 6.3, compiled on Dec 16 2016 at 13:32:25
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "/Applications/Arduino.app/Contents/Java/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/Users/andreamedola/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/cu.usbmodemFA131
         Using Programmer              : arduino
         Overriding Baud Rate          : 115200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00


I'm on Mac OS Sierra but i tested it also on Windows 10 without results..
I checked the board and the port.. and also the website
http://www.arduino.cc/en/Guide/Troubleshooting#upload

How can i solve this problem?

ballscrewbob

There are some issues with Sierra so maybe do a search for that in particular. (not a mac guy BTW)

But if you also post the windows stuff I may be able to help.
It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

andrell

I just try it on Linux (ubuntu 14 i think..) and it says the same

Code: [Select]

avrdude: Version 6.3, compiled on Dec 16 2016 at 07:33:21
        Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
        Copyright (c) 2007-2014 Joerg Wunsch

        System wide configuration file is "/home/andrea/Documenti/Arduino/arduino-1.8.1/hardware/tools/avr/etc/avrdude.conf"
        User configuration file is "/root/.avrduderc"
        User configuration file does not exist or is not a regular file, skipping

        Using Port                    : /dev/ttyACM0
        Using Programmer              : arduino
        Overriding Baud Rate          : 115200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
etc....


I don't know what can i try to do..

BobKay

For some reason he's looking in root's home directory for a config file.  If you're using the IDE as a normal user, he's not going to let you look in root's home.

I'm guessing you may have run the IDE as root, possibly the first time you ran it.

andrell

#4
Feb 10, 2017, 07:24 pm Last Edit: Feb 10, 2017, 07:57 pm by andrell
I just tried opening it as root but it says the same error.. and also it doesn't create the file!

it passed the loop back test so i think i don't have communication problems!



ballscrewbob

Not sure what the..... you are doing but "up" means NOTHING around here...And if its just to "bump" your thread please be careful as its frowned upon.
It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

Go Up