Go Down

Topic: Arduino Leonardo and duinotech Wifi Shield (Read 9187 times) previous topic - next topic

pert

I attached a picture about what GPIO is (a tab at Flash Download Tool 3.6.4).
Ah. That tool has changed a bit recently and I never even looked at the other tabs. I did look for some documentation on the new tabs but the documentation that comes with the tool seems to be for the old UI.

I could flash my ESP-13 WROOM-02 by using a (quite) older version of the flashing tool (0.9.3.1). Same steps with the latest tool just don't work!
How strange. I did just a few days ago verify that the instructions I posted in reply #25 work for my with my DOIT shield and the latest version of the Flash tool and AT firmware but I was using an FTDI FT232 (actually a counterfeit) adapter.

@pert I used your sketch to use Leonardo as a USBTTL (of course, others can just use a USBTTL as well), set the blue DIP swtches on and used a jumper cable to set the D0 pin to GND.

Then, I followed the instructions at
https://github.com/espressif/ESP8266_NONOS_SDK/blob/master/bin/at/README.md
to flash my shield to the latest AT firmware. It worked like a charm!
Glad to hear! I was actually not certain using the Leonardo that way would work but I didn't see why it shouldn't.

Enjoy!

jlme2tfm

#46
May 07, 2018, 10:13 pm Last Edit: May 07, 2018, 10:34 pm by jlme2tfm
Hi back,

@pert and folks, could you tell me a way to upload an sketch to the ESP-WROOM-02 itself from Arduino IDE? I've noticed that it launches NodeMCU's esptool after compiling the software, but it get stuck connecting (just as the latest version of Flash Download Tool). Any idea with this? Also, which board should I choose from the list? According to this, my wifi board flash size is 16 Mbit (but when flashing the firmware I chose 32 Mbit and it was ok)

On the other hand: I've been thinking about using my old version of Flash Download Tool (the same I used to flash the latest AT firmware from espressif) to "flash" the .bin file obtained from the compiled sketch, but... How I should set the files at the Download Tool? I've tried substituting the user1.bin file to my .bin (when running, I just see garbage at the serial monitor).

My desire is to use the ESP8266 Wifi Library instead of the WifiEsp, so at the moment I'm just trying with simple sketches (like just connect to my wifi network).

Thanks in advance.
Regards.

quamikazee

#47
Nov 25, 2018, 04:52 am Last Edit: Nov 25, 2018, 04:54 am by quamikazee
A year or two ago IIRC, I was able to accomplish this.   Not so recently.

Using Pert's instructions, I have an FTDI232 connected as described.  I have the ESP8266-01 powered by a regulated 3.3v external power source.

I believe I have everything connected as prescribed.   Have checked, double checked, then triple checked....then repeated the checks.


The lights on the Serial adapter blink, and the blue light on the ESP8266 blinks in unison with it...but no connection ever seems to be established.


No matter what all I can get is a timeout.....and this message...


Code: [Select]
CONNECT BAUD: 115200
============
....._____....._____....._____....._____....._____....._____....._____....._____....._____....._____[2018-11-24 22:45:21,884][ESP8266Loader_spi[1]][espDownloader.py][line:351][ERROR]: Chip sync error: Failed to connect to ESP8266: Timed out waiting for packet header
[2018-11-24 22:45:21,884][ESP8266Loader_spi[1]][espDownloader.py][line:439][ERROR]: ESP8266 Chip sync error esp_sync_blocking.



Perhaps this is a simple problem that is caused by a simple setting?
I have literally tried every setting over several hours now to no avail.

quamikazee

And literally....within the next minute after posting this I tried a different ESP8266-01 and of course, it immediately communicated and the information popped up.

Bad ESP8266-01 I suppose.   

pert

I'm glad to hear you got one working at least. I don't know what could be wrong with the first one. Maybe someone else will have an idea.

Go Up