Go Down

Topic: Servo with nano and 3.7V lipo (Read 1 time) previous topic - next topic

Marciokoko

Apr 10, 2017, 06:27 pm Last Edit: Apr 10, 2017, 06:27 pm by Marciokoko Reason: image
Im trying to test the duration of a lipo battery pack rated at 3.7V.  I want to use it to power a nano and a servo that will spin for about 5 seconds every hour.

Im thinking of connecting the battery+ to a rail on the breadboard along with a connection to Vin on the nano and then battery- to the GND on both the nano and the servo.  Does that seem ok?

So as you can see here, on the far left rail of the mini breadboard there is no nano pin, so its free.  Ive connected:

batt-
nano gnd
servo gnd

and on the far right rail which is also free (no nano pins on it), I have connected:

batt+
nano Vin (will plug in)
servo +


srnet

The Nano has an operating voltage of 5V;

https://www.arduino.cc/en/Main/arduinoBoardNano

http://www.50dollarsat.info/
http://www.loratracker.uk/

Marciokoko

OK well I remember something about the barrel jack and usb cable power having a component that drops the power down by about 12v but the Vin doesn't have that.  So if I feed in 7.4V to the Vin I could mess it up, right?

MarkDerbyshire

OK well I remember something about the barrel jack and usb cable power having a component that drops the power down by about 12v but the Vin doesn't have that.  So if I feed in 7.4V to the Vin I could mess it up, right?
I run Nano's on 9V.  The servo will need a minimum of 5V and a max of 6V.  7.4V will toast the servo

Marciokoko

OK so I'll need a regulator for 5v for my incoming 7.4v, right?

MarkDerbyshire

Yes

7.4V to Nano Vin and Regulator Vin
Regulator 5V Output to Servo +V
Connect all GNDs together

Marciokoko

OK but the 7805 output to vin right?

NewStudent

Vin pin connects the input voltage to LDO Regulator so you need to connect it to 5v pin remember that there is no reverse voltage protection or short circuit protection in there so its not recommended but i have used this technic before and it is ok if you be careful.
When life gives you lemons...
              Demand to see life's manager.

MarkDerbyshire

Here is a basic schematic.  There are no signal connections drawn just power

Marciokoko

Mark but in that diagram the related 5v from lm7805 is going to the servo but not to the nano isn't it?  Wouldn't the lm7805 need to be before the Vin on the nano?

MarkDerbyshire

Mark but in that diagram the related 5v from lm7805 is going to the servo but not to the nano isn't it?  Wouldn't the lm7805 need to be before the Vin on the nano?
No.  The Nano runs on 7.4V and the servo runs on the 5V.  If you look at the specs of the nano the input voltage Vin is between 7V and 12V.  It will not run with 5V on Vin

https://www.arduino.cc/en/Main/arduinoBoardNano

Go Up