Go Down

Topic: arduino\hardware\samd\1.6.14\cores\arduino/Arduino.h:48:17: fatal error: sam.h:  (Read 809 times) previous topic - next topic

3dkids

arduino\hardware\samd\1.6.14\cores\arduino/Arduino.h:48:17: fatal error: sam.h: No such file or directory

 #include "sam.h"

                 ^

why ???


IDE 1.8.4

Arduino  MKR1000

example blink...

ballscrewbob

Hmmm IDE 1.8.4 ????
Would that be from the OTHER arduino site maybe ?
Maybe its a beta release in which case bugs are to be expected.

Any chance of additional details like OS, etc etc etc. Things mentioned in THIS THREAD that you passed on the way in.
It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

nanomoog

I also have this issue.

I'm using IDE 1.6.7, on Windows 10

I get the following error message:-

C:\Users\blah\AppData\Local\Arduino15\packages\arduino\hardware\samd\1.6.15\cores\arduino/Arduino.h:48:17: fatal error: sam.h: No such file or directory

#include "sam.h"

I have seen others with the same issue are able to resolve it by removing the samd directory and then re-installing.   I have tried this but not got any further.

I've tried both early and later versions of code - same issue

Google has shown that others have had this issue, but the solutions nearly always seem to be that of re-installing the board in Board Manager.

I can see the MKR1000 in the Com port list, so I know that at least that bit works.

Any ideas, anyone?




nanomoog

ah....it would appear that I'd not gone back in time far enough.
As the current version of SAMD is  1.6.15, I thought I'd go back 5-6 releases.

If I'd gone back to 1.6.7, I'd find one that worked.
Hopefully it will be resolved in 1.6.16, (but I'm not too sure what's happened to versions 1.6.8-15).

Go Up