Go Down

Topic: [Solved] NodeMCU 1.0 (ESP-12E Module) compile error on Ubuntu 17.04 (Read 93 times) previous topic - next topic

CoderInTheSouth

Hi,
I recently installed a fresh new Ubuntu 17.04 Zesty. I'm running IDE 1.8.2.
I use a code that compiled correctly on Ubuntu 16.10 Yakety.
Whenever I start compiling for NodeMCU 1.0 (ESP-12E Module), I get the following error:

Code: [Select]
xtensa-lx106-elf-gcc: fatal error: -fuse-linker-plugin, but liblto_plugin.so not found
compilation terminated.
exit status 1


Any hint?

Thanks in advance

CoderInTheSouth

Problem solved... disappeared should I say.
I reinstalled both IDE 1.8.2 and NodeMCU library from scratch.
Everything works fine now.

Go Up