Go Down

Topic: Removing an incomplete Library (Read 589 times) previous topic - next topic

Ted1

I am testing a barometric pressure sensor BMR280
I have downloaded the appropriate libraries, they come in a "wrapper" to add(zipped) into the Arduino.
The contents are  :-  BMP280.cpp   and BMP280.h   SPI.cpp  and SPI.h

Unfortunately the file BMP.cpp did for some reason not get included when I added it to the Arduino libraries
I have tried to find out how to remove the incomplete "wrapper" from the Arduino file list but I do not know how to do this and it will not just let me overwrite it with the complete set of files.

If I could just delete from the Arduino the incomplete "wrapper" and start again all would be well as I have all the files required.

You can see by this I am very new to Arduino and what I ask is probably very simple but if you can help please I would be grateful.

pert

You haven't said how you "added it to the Arduino libraries" but I'm going to guess that it was installed to {sketchbook folder}/libraries. You can find the location of the sketchbook folder at File > Preferences > Sketchbook Location So you just need to open that folder, find the folder containing the "incomplete library", and delete it. Please be very careful when deleting files on your computer. If in doubt, back up!

Ted1

Many thanks for your reply.

I initially downloaded the ZIP file containing a set of files for the BMP280  I unzipped them and not knowing any better, (first time for this),  I thought that I would need to select the   "dot h" file only then I went into    sketch  --include libraries and then install ZIP file.  so it only had the one file in the installed folder.

I have tried your suggestion but it just leads me to a list of the sketches that I have tried but no list of libraries.  I feel somewhere there must be a complete list of libraries --the same list that I see when I look under   sketch>include library

I have tried looking in the Sketch>include libraries>manage libraries       but that just shows me libraries but they cant seem to be edited or removed.
Perhaps I have missed something in your suggestion?

Again many thanks for your interest and time .

pert

I'm talking about folders on your computer. Not the menus of the Arduino IDE. Do this:
  • In the Arduino IDE: File > Preferences > Sketchbook location. Note the folder path set in that option.
  • Open a file system browser program on your computer (e.g. Windows Explorer, Finder).
  • Navigate to the sketchbook folder location
  • Navigate to the "libraries" subfolder of the sketchbook folder.
  • Look through the subfolders of the libraries folder until you find the BMP280 library.

Ted1


Ted1

Hi again

Very many thanks --I understand now and I have done as you suggested and it is all fine --I have loaded the complete  library now.

I am sorry I was a bit slow but thanks for persevering. I can progress now.

All best wishes and thanks for your time

pert

Glad to hear you got it working, and learned a little about how the Arduino IDE stores libraries too! Enjoy!

Go Up