Go Down

Topic: Difficulty initializing with an OSEPP shield and an SDHC microSD (Read 489 times) previous topic - next topic

ItsAPhaseLocked

Hey Arduino Community,

So I'm having difficulty initializing a microSD card and I'm getting the same error codes on two separate Arduinos. I've attempted hard and soft SPI communication through the Sdfat library.

The SDshield I'm using has a 74HC4050D hex shifter. I have tried through an UnoR3's ISCP, Leo's ISCP, Uno's D11-13, Uno's soft D7-10 and I'm consistently getting the same error code.

When I run SDInfo.ino the serial monitor spits out:

Quote
Assuming the SD is the only SPI device.
Edit DISABLE_CHIP_SELECT to disable another device.

Assuming the SD chip select pin is: 8
Edit SD_CHIP_SELECT to change the SD chip select pin.
error: cardBegin failed
SD errorCode: 0X20,0XFF
I've done continuity tests on all of the lines on the sdshield and I've formatted my SDHC 16gb micro using the offical 4.0 SD formatter.

My next step is to borrow a friend's Red Pitaya and actually monitor the hex converter's output but in the meantime I was hoping maybe someone has either run into this problem before or knows what the 0x20 error refers to.

Any insight would be greatly appreciated. I'm just a little frustrated since I've handled sdshields in the past with jtag/atmel studios and I've never ran into this initialization problem before. I'm guessing it could be a bad hex converter?

Go Up