Go Down

Topic: Collegamento relè e sensori umidità tramite alimentatore esterno (Read 947 times) previous topic - next topic

zovo

Ciao a tutti, vorrei automatizzare l'irrigazione di numerosi vasi di peperoncini che sto mandando avanti da febbraio. Ho l'esigenza di fare un'irrigazione automatica in quanto a giugno parto per più di un mese e non ho nessuno che possa prendersene cura.
Ho acquistato 15 sensori di umidità, 12 elettrovalvole, un modulo relè e vorrei fare nel seguente modo:
collego 6 sensori al relè che li alimenta tramite un alimentatore esterno a 5 V (YW robot 545043); viene attivato ogni 30 minuti e mi legge i valori, attivando un secondo relè che attiva l'elettrovalvola se l'umidità scende al di sotto di una soglia impostata.
Il problema è che collegando i sensori a un alimentatore esterno Arduino non effettua letture coerenti, "spara" numeri a caso. Credo che ci sia da fare qualche collegamento tra Arduino e alimentatore, ma ho paura di bruciare qualcosa.
Qualche suggerimento?
Grazie a tutti!

zovo

Grazie, ho provato e Arduino funziona! Come faccio però a leggere l'uscita seriale, dato che ho alimentato Arduino tramite l'USB dell'alimentatore?

gpb01

Su Arduino UNO ORIGINALE c'è un circuito per escludere un'alimentazione in presenza di un'altra, ma ... nei cloni cinesi spesso NON c'è o funziona male quindi ... hai un Arduno originale o un clone ?

Guglielmo
Search is Your friend ... or I am Your enemy !

zovo


gpb01

Sui cloni NON posso darti alcuna assicurazione che la cosa funzioni ... ne ho personalmente visti "fumare" più di uno a causa delle due alimentazioni ... ::)

Guglielmo
Search is Your friend ... or I am Your enemy !

gpb01

ti taglia il cavo, si scollega il + , si collega il secondo alimentatore (rigorosamente 5v stabilizzati con buona capacità di carico) al USB che va all'arduino, GND in comune tra arduino, PC, alimentatore
SI, se cerchi c'è già stato molto tempo fa un altro thread in cui si è risolto così, ma ... è un opzione che richiede una certa  "esperienza" e "manualità", altrimenti ... il danno è certo :D :D :D

Guglielmo
Search is Your friend ... or I am Your enemy !

gpb01

ma te te li ricordi tutti?
... solo i più interessanti  :smiley-mr-green:  e quello lo era perché c'erano di mezzo varie cosette ...

Il problema, purtroppo, è ritrovarli ... di quelli veramente importanti salvo il link in un file ... gli altri ... a volte San Google li trova (specie se magari ti ricordi anche i nick dei partecipanti e li metti nella ricerca) altre ... c'è poco da fare ...

Guglielmo
Search is Your friend ... or I am Your enemy !

zovo

I sensori (sono degli YL-69) assorbono max 40mA l'uno, tenterò la modifica al cavo usb! Comunque ho risolto leggendo l'uscita digitale (pare che quella funzioni)! Però voglio tentare come mi avete consigliato.

Go Up