Go Down

Topic: Arduino 015 - not working (Read 5165 times) previous topic - next topic

awong68

Hi everybody,
I hope you guys can help or point me to a correct direction.  I have Arduino 015 installed at my home computer and it is working fine.  However, I can't get Arduino 015 to run at my work computer.  Both computers are using WindowXPpro.  I deleted and re-download the Arduino 015 on my work PC, and still having the same problem :(  I want to use Arduino 015 on my work pc because I just got the Arduino Mega.  Currently for my work pc, i'm using Arduino 013 and its working fine, except I can't use the Arduino Mega.  Please see the error message below I get when running Arduino 015 at my work PC.

java.io.IOException: Target platform: "null" not found.
Make sure that "build.target" in the
preferences file points to a subdirectory of
C:\arduino-0015\hardware\cores

     at processing.app.Target.<init>(Target.java:49)

     at processing.app.LibraryManager.<init>(LibraryManager.java:50)

     at processing.app.Sketchbook.buildMenu(Sketchbook.java:433)

     at processing.app.Sketchbook.rebuildMenus(Sketchbook.java:374)

     at processing.app.Sketchbook.rebuildMenusAsync(Sketchbook.java:358)

     at processing.app.Sketchbook.handleNew(Sketchbook.java:229)

     at processing.app.Editor.handleNew2(Editor.java:1724)

     at processing.app.Editor.restorePreferences(Editor.java:464)

     at processing.app.Base.<init>(Base.java:155)

     at processing.app.Base.main(Base.java:104)

java.io.IOException: Target platform: "null" not found.
Make sure that "build.target" in the
preferences file points to a subdirectory of
C:\arduino-0015\hardware\cores

     at processing.app.Target.<init>(Target.java:49)

     at processing.app.LibraryManager.<init>(LibraryManager.java:50)

     at processing.app.Sketchbook.buildMenu(Sketchbook.java:433)

     at processing.app.Sketchbook.rebuildMenus(Sketchbook.java:376)

     at processing.app.Sketchbook.rebuildMenusAsync(Sketchbook.java:358)

     at processing.app.Sketchbook.handleNew(Sketchbook.java:229)

     at processing.app.Editor.handleNew2(Editor.java:1724)

     at processing.app.Editor.restorePreferences(Editor.java:464)

     at processing.app.Base.<init>(Base.java:155)

     at processing.app.Base.main(Base.java:104)

java.io.IOException: Target platform: "null" not found.
Make sure that "build.target" in the
preferences file points to a subdirectory of
C:\arduino-0015\hardware\cores

     at processing.app.Target.<init>(Target.java:49)

     at processing.app.LibraryManager.<init>(LibraryManager.java:50)

     at processing.app.Sketchbook.buildMenu(Sketchbook.java:433)

     at processing.app.Sketchbook.rebuildMenus(Sketchbook.java:374)

     at processing.app.Sketchbook.rebuildMenusAsync(Sketchbook.java:358)

     at processing.app.Editor.applyPreferences(Editor.java:524)

     at processing.app.Editor.restorePreferences(Editor.java:477)

     at processing.app.Base.<init>(Base.java:155)

     at processing.app.Base.main(Base.java:104)

java.io.IOException: Target platform: "null" not found.
Make sure that "build.target" in the
preferences file points to a subdirectory of
C:\arduino-0015\hardware\cores

     at processing.app.Target.<init>(Target.java:49)

     at processing.app.LibraryManager.<init>(LibraryManager.java:50)

     at processing.app.Sketchbook.buildMenu(Sketchbook.java:433)

     at processing.app.Sketchbook.rebuildMenus(Sketchbook.java:376)

     at processing.app.Sketchbook.rebuildMenusAsync(Sketchbook.java:358)

     at processing.app.Editor.applyPreferences(Editor.java:524)

     at processing.app.Editor.restorePreferences(Editor.java:477)

     at processing.app.Base.<init>(Base.java:155)

     at processing.app.Base.main(Base.java:104)

java.io.IOException: Target platform: "null" not found.
Make sure that "build.target" in the
preferences file points to a subdirectory of
C:\arduino-0015\hardware\cores

     at processing.app.Target.<init>(Target.java:49)

     at processing.app.LibraryManager.<init>(LibraryManager.java:50)

     at processing.app.Editor.prepareLibraries(Editor.java:383)

     at processing.app.Base.<init>(Base.java:161)

     at processing.app.Base.main(Base.java:104)

java.io.IOException: Target platform: "null" not found.
Make sure that "build.target" in the
preferences file points to a subdirectory of
C:\arduino-0015\hardware\cores

     at processing.app.Target.<init>(Target.java:49)

     at processing.app.LibraryManager.<init>(LibraryManager.java:50)

     at processing.app.Sketchbook.buildMenu(Sketchbook.java:433)

     at processing.app.Sketchbook.rebuildMenus(Sketchbook.java:374)

     at processing.app.Editor.prepareLibraries(Editor.java:394)

     at processing.app.Base.<init>(Base.java:161)

     at processing.app.Base.main(Base.java:104)

java.io.IOException: Target platform: "null" not found.
Make sure that "build.target" in the
preferences file points to a subdirectory of
C:\arduino-0015\hardware\cores

     at processing.app.Target.<init>(Target.java:49)

     at processing.app.LibraryManager.<init>(LibraryManager.java:50)

     at processing.app.Sketchbook.buildMenu(Sketchbook.java:433)

     at processing.app.Sketchbook.rebuildMenus(Sketchbook.java:376)

     at processing.app.Editor.prepareLibraries(Editor.java:394)

     at processing.app.Base.<init>(Base.java:161)

     at processing.app.Base.main(Base.java:104)


Coding Badly

Try this...


  • Do your best to get Arduino running
  • Click the menu item File then Preferences
  • Find, at the bottom of the dialog, the phrase "More preferences can be edited..."
  • Below that is the path to the preferences file
  • Open Explorer
  • Navigate to the folder that contains the preferences file (for example, mine is "C:\Users\Brian\AppData\Roaming\Arduino\")
  • Open "preferences.txt" in Notepad (or another text file editor)


Is "preferences.txt" in that folder?

Is "build.target" in your "preferences.txt" file?


- Brian

awong68

Yes, preferences.txt is in the folder (File->Preference).  However, "build.target" is not in the "preferences.txt".  I'm still puzzle why I'm able to get Arduino 015 working at my home computer, but not at my job.  Both PC are running WindowXP Professional.

Anybody else have this same issue?  I also checked to make sure I have the latest Java installed, and yes it is.

Coding Badly

My suspicion was that it was a wrong path problem or a security problem.  The evidence doesn't really support either theory.

In other words, I'm baffled.  Hopefully, someone else can help.

Good luck,
Brian

awong68

Brian,
Thanks for helping, and i'm still getting nowhere.  Maybe it can be a path problem, not security because i'm the admin for that PC, and I manage the IT of the shop.  I already disable window's firewall, download the latest java, etc., still not working.  With over 80 views, and no one can suggest? Mmmm... am I the only one with this issue? Oh well, i guess i'll try to resolve it as soon and will let you know if I get it resolved.  There gotta be something i'm missing.


Coding Badly

I have another theory...


  • Close Arduino
  • Locate and open the preferences.txt file
  • Locate and delete the line that starts with last.sketch.path
  • Close and save preferences.txt
  • Start Arduino


Any luck?

- Brian

mellis

Try selecting a different board from the Tools > Board menu, then restarting the Arduino environment.  Or check for the "board" preference in preferences.txt and let us know what it is.

awong68

Mellis,
Thank you for the tip.  I did exactly what you said, and now it's working with no issue.  Something so simple, yet I didn't think of it.  Well, I know next time.  Time to put back all the security and make sure it's working after that.  Thanks to Brian and Mellis to chimming in and their assistance.


sambrutus

Hi people,

I have the exact same problem as ASC, but i can't find my "preferences.txt". I use WinXPPro. Can you help locate it ? thanks.

Coding Badly

#9
May 21, 2009, 03:14 am Last Edit: May 21, 2009, 03:15 am by bcook Reason: 1
Have you tried the suggestion from millis (reply #6)?

The very first reply has detailed instructions for locating the preferences.txt file.  Is preferences.txt not in that directory?

- Brian

sambrutus

#10
May 21, 2009, 05:04 am Last Edit: May 21, 2009, 05:09 am by sambrutus Reason: 1
The "preferences" file is not in my in my \arduino-0015\hardware\cores folder. There's only 3 other folder named "arduino" "atmega8" and "blank", none of which contain the "preferences" file.

EDIT: I can't open Arduino at all, so i cannot go see the exact location of the file, plus i tried a search and it didn't return any results.

Thanks !

Coding Badly

Quote
I can't open Arduino at all


Which means you are not having the same problem as the original poster.

What error message(s) are displayed when you try to run Arduino?

- Brian

sambrutus

None. There's no message at all. I double click it, then nothing happens.

Coding Badly

Unfortunately, I'm not going to be any help.  I have no idea what to suggest.

Hopefully someone else can offer some ideas.

- Brian

Actives

Hello, Everyone

i have the same problem, i try to search over the internet and no way to resolve this issue. waiting for any body help

Thank in advance

Go Up