Go Down

Topic: problema robot 7 servos (Read 1 time) previous topic - next topic

tecnoamoros

Hola.

Somos estudiantes de secundaria que estamos intentando hacer un robot humanoide don una arduino uno genuina y 7 servos futaba s3003 originales.

Tanto la placa como los servos los alimentamos con una batería de 7,4 (en clase con una fuente de alimentación) , previo paso por un regulador de tensión que nos da un voltaje teórico de 6v. De ahí a una regleta donde conecto todas los +6v y todas las tierras. El programa está aparentemente bien, ya que cuando le de la gana, el robot funciona de maravilla.

El problema es que, sin saber por qué, en un momento dado deja de hacerlo, como si los servos no tuviesen fuerza. Hemos revisado todo y no parece que sea problema de mala conexión o similar.¿Se os ocurre algo? ¿tiene la arduino uno limitaciones para mover 7 servos de esas características? ¿algun tipo de reseteo de servos?

Pretendíamos acabar hoy, ya que necesitamos el robot para el sábado, pero me temo que el trabajo de varios meses se va al traste  :'(  :'(  :'(  :'(

Gracias de antemano

Saludos

GO_zalo

Habéis conectado las tierras entre sí del arduino u de la batería??

Danicap

Cuanto consume cada servo? Igual le estáis pidiendo demasiado al arduíno y no da para tanto, si es así con etapas amplificadoras a las entradas de los servos lo solucionaríais.

tecnoamoros

Buenos días:

Tal y como sospechábamos, hemos conectado nuestro robot y funciona correctamente, aunque las esperanzas de que lo haga durante tiempo son nulas. Es como si se "cansase". Vamos a probar un par de cosas, alimentar independientemente placa y servos y reforzar las conexiones. Go_zalo, gracias, sí, hemos conectado las tierras. Danicap, gracias, somos alumnos de 4º de la ESO y el tema de amplificar ya se nos va de las manos. De todos modos, estamos alimentando con una fuente de alimentación que parece la central de Cofrentes...

Gracias, seguimos intentándolo! Si se os ocurre qué puede pasar, os lo agradeceremos!

Saludos!


tecnoamoros

Se confirma, no funciona... :smiley-confuse:

Danicap

Puedes subir un esquema de como tienes todo conectado? Características de los servos?

tecnoamoros

Los servos son futaba s3003, tenemos una regleta par tierra y otra para +6v donde van todos los cables de tención de los servos, los pines de señal a la arduino, y ahora la arduino alimentada por una bateria externa. Tanto la tarjeta como los servos tienen tierra comun. Gracias por el interés.

surbyte

#7
May 12, 2017, 04:14 pm Last Edit: May 12, 2017, 04:23 pm by surbyte
Me veo obligado a editar toda la respuesta ya que has respondido lo que preguntaba luego.

Es posible que los servos consumen mas de lo que puede entregar tu fuente? Han medido consumos?

Consume 8mA en reposo a 6V segun esta hoja de datos

No esta claro pero hablan de corrientes de 250mA por servo y ya que dice soportar 7.6W podría si no tuviera péridas consumir hasta 1.3A.

Asi que tu problema es que han menospreciado el consumo de los servos para el torque que necesita.

tecnoamoros

Gracias surbyte. Lo que se nos escapa es que esté funcionando 40, 50 minutos y de repente no funcione....
Los servos los tenemos conectados a una fuente de alimentación de laboratorio.., creemos  que suministra intensidad de sobra.

Muchas gracias, no le encontramos la lógica

surbyte

Bien... pero las fuentes de laboratorio suelente tener un limite de corriente. Verifiquen cual es?
Funciiona 40 o 50 mintuos pero no esta los 40 min en reposo, esta moviendose o casualmente estan todos los servos moviéndose en simultáneo?

A ver.. lo mio es una hipótesis. Para confirmarla deben probar Uds. Sometan al robot a máximo esfuerzo con todos los servos en movimiento y máximo torque desde el vamos.
A ver si funciona o no?

De lo contrario estuidemos el código a ver si algo puede darnos una pista.

tecnoamoros

...Tenemos picos de 2 A...

surbyte


tecnoamoros

Con el amperímetro de la fuente de alimentación. Bueno, gracias a todos por vuestros comentarios. Al final el robot funcionó, aunque no hizo nada de lo que tenía que hacer. Recablearemos todo, reprogramaremos todo..., misterios sin resolver.

Saludos!

Go Up