Go Down

Topic: CardInfo with microSD card using the Arduino Wireless SD Shield (Read 820 times) previous topic - next topic

Xylord

Hello all!
This is a straightforward one, at least I thought it was.
The hardware:

- Arduino Mega 2560 https://www.arduino.cc/en/main/arduinoBoardMega2560
- Arduino Wireless SD Shield https://www.arduino.cc/en/Main/ArduinoWirelessShield
- Adafruit microSD https://www.adafruit.com/product/102

The microSD has been formatted by right clicking it in my laptop, selecting "Format", unchecking the "Quick Format" option, selecting the FAT32 format and letting it do its thing.

The shield is properly inserted, all the pins are connected at least (I've tested other projects that made use of those pins) and the 6 pins in the middle are connected as well.

I am presently trying to use this example sketch:
Code: [Select]
// include the SD library:
#include <SPI.h>
#include <SD.h>

// set up variables using the SD utility library functions:
Sd2Card card;
SdVolume volume;
SdFile root;

// change this to match your SD shield or module;
// Arduino Ethernet shield: pin 4
// Adafruit SD shields and modules: pin 10
// Sparkfun SD shield: pin 8
// MKRZero SD: SDCARD_SS_PIN
const int chipSelect = 4;

void setup() {
  // Open serial communications and wait for port to open:
  Serial.begin(9600);
  while (!Serial) {
    ; // wait for serial port to connect. Needed for native USB port only
  }


  Serial.print("\nInitializing SD card...");

  // we'll use the initialization code from the utility libraries
  // since we're just testing if the card is working!
  if (!card.init(SPI_HALF_SPEED, chipSelect)) {
    Serial.println("initialization failed. Things to check:");
    Serial.println("* is a card inserted?");
    Serial.println("* is your wiring correct?");
    Serial.println("* did you change the chipSelect pin to match your shield or module?");
    return;
  } else {
    Serial.println("Wiring is correct and a card is present.");
  }

  // print the type of card
  Serial.print("\nCard type: ");
  switch (card.type()) {
    case SD_CARD_TYPE_SD1:
      Serial.println("SD1");
      break;
    case SD_CARD_TYPE_SD2:
      Serial.println("SD2");
      break;
    case SD_CARD_TYPE_SDHC:
      Serial.println("SDHC");
      break;
    default:
      Serial.println("Unknown");
  }

  // Now we will try to open the 'volume'/'partition' - it should be FAT16 or FAT32
  if (!volume.init(card)) {
    Serial.println("Could not find FAT16/FAT32 partition.\nMake sure you've formatted the card");
    return;
  }


  // print the type and size of the first FAT-type volume
  uint32_t volumesize;
  Serial.print("\nVolume type is FAT");
  Serial.println(volume.fatType(), DEC);
  Serial.println();

  volumesize = volume.blocksPerCluster();    // clusters are collections of blocks
  volumesize *= volume.clusterCount();       // we'll have a lot of clusters
  volumesize *= 512;                            // SD card blocks are always 512 bytes
  Serial.print("Volume size (bytes): ");
  Serial.println(volumesize);
  Serial.print("Volume size (Kbytes): ");
  volumesize /= 1024;
  Serial.println(volumesize);
  Serial.print("Volume size (Mbytes): ");
  volumesize /= 1024;
  Serial.println(volumesize);


  Serial.println("\nFiles found on the card (name, date and size in bytes): ");
  root.openRoot(volume);

  // list all files in the card with date and size
  root.ls(LS_R | LS_DATE | LS_SIZE);
}


void loop(void) {

}


I've tried all the suggested options for chipSelect, as well as 53, 52, 51 and 50.

I've also tried setting the chipSelect pinMode to OUTPUT and did digitalWrite(chipSelect, LOW) or digitalWrite(chipSelect, HIGH) during my attempts.

I've found a lot of threads on this subject, but it seems like they all have different solutions and none of them use the same shield as me.

Thank you in advance for any help you can provide!

Xylord

I forgot to mention it since it's kinda obvious, but it's not working and I'm getting this message:

Code: [Select]
initialization failed. Things to check:
* is a card inserted?
* is your wiring correct?
* did you change the chipSelect pin to match your shield or module?


Edit: It might be worth mentionning I've also tried formatting with SDFormat (https://www.sdcard.org/downloads/formatter_4/eula_windows/index.html), didn't help.

Xylord

Alright, figured it out. While the digital/analog pins were far enough in to have a connection, I think the six pins for the SPI weren't quite there yet. I pushed in another few mm while installing the XBee and when I tried again it worked! I used pin 4 as the CS. No need to the digitalWrite(CS, LOW); stuff.

Go Up