Go Down

Topic: WInterrupts.c:138: error: 'INT1' undeclared (first (Read 1 time) previous topic - next topic

pyctam

Hi,

would you please to help me compile sketch on Fedora Core 7, I always get below code :

Code: [Select]

unknown MCU 'atmega328p' specified
Known MCU names:
  avr2
  at90s2313
  ... [list of MCUs] ...
  attiny15
  attiny28
/home/dev/usersoft/arduino-0017/hardware/cores/arduino/WInterrupts.c:1: error: MCU 'atmega328p' supported for assembler only
/home/dev/usersoft/arduino-0017/hardware/cores/arduino/WInterrupts.c: In function 'attachInterrupt':
/home/dev/usersoft/arduino-0017/hardware/cores/arduino/WInterrupts.c:90: error: 'EICRA' undeclared (first use in this function)
/home/dev/usersoft/arduino-0017/hardware/cores/arduino/WInterrupts.c:90: error: (Each undeclared identifier is reported only once
/home/dev/usersoft/arduino-0017/hardware/cores/arduino/WInterrupts.c:90: error: for each function it appears in.)
/home/dev/usersoft/arduino-0017/hardware/cores/arduino/WInterrupts.c:90: error: 'ISC00' undeclared (first use in this function)
/home/dev/usersoft/arduino-0017/hardware/cores/arduino/WInterrupts.c:90: error: 'ISC01' undeclared (first use in this function)
/home/dev/usersoft/arduino-0017/hardware/cores/arduino/WInterrupts.c:91: error: 'EIMSK' undeclared (first use in this function)
/home/dev/usersoft/arduino-0017/hardware/cores/arduino/WInterrupts.c:91: error: 'INT0' undeclared (first use in this function)
/home/dev/usersoft/arduino-0017/hardware/cores/arduino/WInterrupts.c:94: error: 'ISC10' undeclared (first use in this function)
/home/dev/usersoft/arduino-0017/hardware/cores/arduino/WInterrupts.c:94: error: 'ISC11' undeclared (first use in this function)
/home/dev/usersoft/arduino-0017/hardware/cores/arduino/WInterrupts.c:95: error: 'INT1' undeclared (first use in this function)
/home/dev/usersoft/arduino-0017/hardware/cores/arduino/WInterrupts.c: In function 'detachInterrupt':
/home/dev/usersoft/arduino-0017/hardware/cores/arduino/WInterrupts.c:135: error: 'EIMSK' undeclared (first use in this function)
/home/dev/usersoft/arduino-0017/hardware/cores/arduino/WInterrupts.c:135: error: 'INT0' undeclared (first use in this function)
/home/dev/usersoft/arduino-0017/hardware/cores/arduino/WInterrupts.c:138: error: 'INT1' undeclared (first use in this function)


and below list of dependencies
Code: [Select]

Package uisp - 20050207-1.fc7.x86_64 is already installed.
Package avr-libc - 1.4.6-4.fc7.noarch is already installed.
Package avr-gcc-c++ - 4.1.2-4.fc7.x86_64 is already installed.
Package avr-gcc - 4.1.2-4.fc7.x86_64 is already installed.
Package avr-binutils - 2.17-3.fc7.x86_64 is already installed.


Regards

pyctam

please ignore previous post.

the problem was solved by removing avr-libc, avr-gcc-c++, avr-gcc, avr-binutils packages with yum and installing them manually follwing instructions on http://www.pololu.com/docs/0J31/all


Go Up