Go Down

Topic: MOSFET pour des capteurs de température (Read 2143 times) previous topic - next topic

keaume

Voilà ! Je vais test mais je ne sais pas si cela va changer quelque chose.

L'autre partie du breadboard il y a un capteur de courant, un débitmètre et un capteur de pression pour ça que je l'ai pas mentionné

Voilà le branchement en PJ

Artouste

Voilà ! Je vais test mais je ne sais pas si cela va changer quelque chose.
Perso , j'ai plutot tendance à penser que si c'est une préconisation impérative du constructeur , c'est que ça doit quand même être quelque part ...un peu... important :smiley-mr-green:

keaume

EUUUUUUUUUH JE REVE OU CA VIENS DE TOUT REGLER ?????

Faut que je vois ça sur le long terme mais on dirait bien que ça a aidé à stabiliser la plupart des sondes

Artouste

EUUUUUUUUUH JE REVE OU CA VIENS DE TOUT REGLER ?????

Faut que je vois ça sur le long terme mais on dirait bien que ça a aidé à stabiliser la plupart des sondes
:smiley-mr-green:
ça n'a pas aidé à stabiliser quoique ce soit ...
tu a simplement "oublié/omis/etc" de mettre un composant obligatoire pour le fonctionnement des MAX

- une simple lecture du datasheet et le probleme etait réglé

en gros tu a déjà eu de la chance que ça "marchotte" avec 3 modules :D

par curiosité , tu veux gerer quoi avec ta mega ?

keaume

Okay pour l'instant les 4 mesures tiennent dans des valeurs à peu près égal (à 1degré près)

Est-ce que tu pourrais expliquer le changement ?


J'ai aussi des soucis de virgules, cela ne m'affiche pas valeurs avec arrondissement on va dire. Par exemple :
28,61 ou bien 21,28 tu vois, j'aimerais qu'il y ait que des 21,1 ; 21,2 ; 21,3 ; 21,4 ect...


Comment pourrais-je faire ça ?


Pour te répondre j'aimerais récupérer les données de ma machine géothermique à mon domicile et l'envoyer un serveur Thingspeak via un ESP8266. Pour les mesures j'ai 4 MAX31850K-Thermocouple K, deux SCT-013-000 pour le courant (dont j'ai également un problème lol), un débitmètre Digiten G1, et un un capteur de pression. Dans mon circuit j'ai également un Logic level converter pour gérer plus facilement l'ESP8266, voilà ! :)

Artouste

Okay pour l'instant les 4 mesures tiennent dans des valeurs à peu près égal (à 1degré près)

Est-ce que tu pourrais expliquer le changement ?

...

Pour te répondre j'aimerais récupérer les données de ma machine géothermique à mon domicile et l'envoyer un serveur Thingspeak via un ESP8266. Pour les mesures j'ai 4 MAX31850K-Thermocouple K, deux SCT-013-000 pour le courant (dont j'ai également un problème lol), un débitmètre Digiten G1, et un un capteur de pression. Dans mon circuit j'ai également un Logic level converter pour gérer plus facilement l'ESP8266, voilà ! :)
- le changement ? :smiley-mr-green: c'est simplement que la R de 4.7K est là pour assurer des transitions "franches" entre 0 et 1 sur le bus 1-Wire , si elle n'est pas implantée tu reçois plus ou moins de la bouillie (des fois çamarch, des fois çamarchpu 8)  )

- j'ai l'impression que tu te monte "une usine à gaz" avec Mega+Esp8266
un esp8266 en module genre NodeMCU peut surement faire le job (avec tes capteurs) tout seul

perso j'utilise thingspeak sans probleme avec cette base

keaume

Malheureusement t'arrives trop tard j'ai déjà fais toute cette partie (et j'ai tout documenté lol)

Tu me conseilles de mettre une autre résistance 4.7K ou bien une seule suffit ?

Tu t'y connais en calibration/branchement de SCT-013-000 parce que je dois avoir un soucis tout aussi bête lol

Artouste

#22
Jun 01, 2017, 10:02 pm Last Edit: Jun 01, 2017, 10:04 pm by Artouste
Tu me conseilles de mettre une autre résistance 4.7K ou bien une seule suffit ?

::)
Quand j'écris plus haut

Quote
une seule R 4.7K entre VCC et DQ
Tu en déduis quoi ? 8)

perso , j'aurais tendance à penser que tu... ne lis pas , mais que tu survole ... ;)

keaume

En effet,

Je te remercie pour tes réponses précieuses !

Et pour mon histoire de capteur de courant? :)

Artouste

En effet,

Je te remercie pour tes réponses précieuses !

Et pour mon histoire de capteur de courant? :)
Pas joué avec

keaume

Comment ça ?


Je m'excuse j'avais oublié l'histoire d'une seule résistance. Et pour mon calibrage avec une échelle de 0,1 tu as une idée ?

Encore merci,

Artouste

Comment ça ?
je ne connais pas ton capteur de courant , je n'ai donc aucune "reponse" là dessus

keaume

https://forum.arduino.cc/index.php?topic=480821.0


J'ai créé un topic à ce sujet si jamais tu veux jeter un coup d'oeil

Artouste

https://forum.arduino.cc/index.php?topic=480821.0


J'ai créé un topic à ce sujet si jamais tu veux jeter un coup d'oeil
J'avais déjà  lu 8)

Go Up