Go Down

Topic: the serial port does not exist or your board is not connected (Read 7003 times) previous topic - next topic

nekonutchi

I'm suspecting the bootloader might be broken on my Gemma... When i try to upload a sketch, it fails with the error message "the selected serial port does not exist or your board is not connected"...  I am using Windows 10 and this additional dialog pops up when i connect the Gemma with a USB-cord:

imgur-link
I've tried searching for various soultions, e.g reinstalling the drivers, changing the port etc. but nothing has worked so far.
Any help  or suggestions on what else to try is greatly appreciated!

DrAzzy

Are you pressing the reset button immediately before attempting to upload?

Are you trying to use it in a USB 3.0 port? The Gemma is a VUSB device (ie, doesn't actually comply with USB standard, but is "pretty close") and as a result, it is particularly prone to compatibility issues. Try connecting it through a hub.
ATTinyCore for x4/x5/x61/x7/x8/x41/1634/828/x313 megaTinyCore for the megaavr ATtinies - Board Manager:
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts, mosfets, awesome prototyping board in my store http://tindie.com/stores/DrAzzy

nekonutchi

Yes, and it's blinking red right after i press it (as it should when listening for instructions iirc).

I haven't tried using a hub, but several different cords, and the one i'm using now is USB-2.0...

Go Up